aboutsummaryrefslogtreecommitdiff
path: root/contrib/scripts/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-12-01 23:19:58 +0000
committerng0 <ng0@n0.is>2019-12-01 23:19:58 +0000
commitd9132e1cba66b5455a627251f377cd95eb008fc1 (patch)
treed826c9e7793e6c0161d40bc56b577448f22c653c /contrib/scripts/Makefile.am
parent93330d9c6d8d5c599a2f12d641c5029aab91d3ad (diff)
downloadgnunet-d9132e1cba66b5455a627251f377cd95eb008fc1.tar.gz
gnunet-d9132e1cba66b5455a627251f377cd95eb008fc1.zip
convert texinfo checks to proper awk script, add detection for awk/gawk,
remove obsolete code.
Diffstat (limited to 'contrib/scripts/Makefile.am')
-rw-r--r--contrib/scripts/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/contrib/scripts/Makefile.am b/contrib/scripts/Makefile.am
index 367e5c4c9..b76e57db7 100644
--- a/contrib/scripts/Makefile.am
+++ b/contrib/scripts/Makefile.am
@@ -9,7 +9,8 @@ noinst_SCRIPTS = \
9 removetrailingwhitespace.py \ 9 removetrailingwhitespace.py \
10 gnunet_pyexpect.py \ 10 gnunet_pyexpect.py \
11 gnunet_janitor.py \ 11 gnunet_janitor.py \
12 gnunet-chk.py 12 gnunet-chk.py \
13 check-texinfo.awk
13 14
14bin_SCRIPTS = \ 15bin_SCRIPTS = \
15 gnunet-bugreport \ 16 gnunet-bugreport \
@@ -24,12 +25,13 @@ EXTRA_DIST = \
24 $(SCRIPTS) \ 25 $(SCRIPTS) \
25 removetrailingwhitespace.py.in \ 26 removetrailingwhitespace.py.in \
26 pydiffer.py.in \ 27 pydiffer.py.in \
27 gnunet-suidfix 28 gnunet-suidfix \
29 check-texinfo.awk.in
28 30
29CLEANFILES = \ 31CLEANFILES = \
30 $(noinst_SCRIPTS) 32 $(noinst_SCRIPTS)
31 33
32do_subst = $(AWK) -v py="$(PYTHON)" '{gsub("@PYTHONEXE@",py); print $$0}' 34do_subst = $(AWK) -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" '{if (/@AWKEXE@/) { gsub("@AWKEXE@",awkay)}; gsub("@PYTHONEXE@",py); print $$0}'
33 35
34# Use SUFFIX Extension rules, they are more portable for every 36# Use SUFFIX Extension rules, they are more portable for every
35# implementation of 'make'. 37# implementation of 'make'.
@@ -46,3 +48,7 @@ SUFFIXES = .py.in .py
46.py.in.py: 48.py.in.py:
47 $(do_subst) < $< > $@ 49 $(do_subst) < $< > $@
48 chmod +x $@ 50 chmod +x $@
51
52check-texinfo.awk: check-texinfo.awk.in Makefile
53 $(do_subst) < $(srcdir)/check-texinfo.awk.in > check-texinfo.awk
54 chmod +x check-texinfo.awk