aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-08-12 19:09:52 +0000
committerChristian Grothoff <christian@grothoff.org>2013-08-12 19:09:52 +0000
commit5e05019536c0d38bf20f965613636f21ae7c2be6 (patch)
treeeda1dee12e49c010171462d618162d28b21c9c6a /src/Makefile.am
parent566dfe32be22ed1f071b974be3c4dd8bc5721151 (diff)
downloadgnunet-5e05019536c0d38bf20f965613636f21ae7c2be6.tar.gz
gnunet-5e05019536c0d38bf20f965613636f21ae7c2be6.zip
-towards namestore support for the new privacy-preserving GNS queries
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 00c4d6f93..d8d3fbf57 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -10,15 +10,17 @@ if HAVE_TESTING
10endif 10endif
11 11
12if HAVE_EXPERIMENTAL 12if HAVE_EXPERIMENTAL
13 EXP_DIR = dv $(CONSENSUS) $(EXPERIMENTATION) 13 EXP_DIR = dv $(CONSENSUS) $(EXPERIMENTATION)
14endif 14endif
15 15
16if LINUX 16if LINUX
17# All of these currently only work on GNU/Linux or W32 17# All of these currently only work on GNU/Linux or W32
18 LINUX_DIR = exit vpn pt 18 LINUX_DIR = exit vpn
19# pt # without namestore, pt currently has some issues...
19endif 20endif
20if MINGW 21if MINGW
21 MINGW_DIR = vpn exit pt 22 MINGW_DIR = vpn exit
23# pt # without namestore, pt currently has some issues...
22endif 24endif
23 25
24if HAVE_MYSQL 26if HAVE_MYSQL
@@ -44,7 +46,6 @@ SUBDIRS = \
44 $(POSTGRES_DIR) \ 46 $(POSTGRES_DIR) \
45 datacache \ 47 datacache \
46 datastore \ 48 datastore \
47 namestore \
48 template \ 49 template \
49 ats \ 50 ats \
50 nat \ 51 nat \
@@ -67,6 +68,7 @@ SUBDIRS = \
67 fs \ 68 fs \
68 $(LINUX_DIR) \ 69 $(LINUX_DIR) \
69 $(MINGW_DIR) \ 70 $(MINGW_DIR) \
70 gns \
71 integration-tests \ 71 integration-tests \
72 $(EXP_DIR) 72 $(EXP_DIR)
73
74# note: namestore, gns are not listed right now as they are being reworked to use the new crypto \ No newline at end of file