aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-06-25 10:06:56 +0000
committerChristian Grothoff <christian@grothoff.org>2013-06-25 10:06:56 +0000
commit5f7b5fb33b16a170fde12325150233f1bc014893 (patch)
tree3288b09252cfb8f5efab3554c3195de282ef27e0 /src/Makefile.am
parent7d6a6d6b4ebfaae41b05a4a948a89520420fcd11 (diff)
downloadgnunet-5f7b5fb33b16a170fde12325150233f1bc014893.tar.gz
gnunet-5f7b5fb33b16a170fde12325150233f1bc014893.zip
fix #2901: fail hard if libidn or header are not found
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 3 insertions, 11 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 62a08cb5a..22b24b9bf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,24 +2,16 @@
2# INTLEMU_SUBDIRS = intlemu 2# INTLEMU_SUBDIRS = intlemu
3#endif 3#endif
4 4
5if HAVE_LIBIDN
6 EXIT = exit
7 PT = pt
8else
9 EXIT =
10 PT =
11endif
12
13if HAVE_EXPERIMENTAL 5if HAVE_EXPERIMENTAL
14 EXP_DIR = gns set dv consensus experimentation 6 EXP_DIR = gns set dv consensus experimentation
15endif 7endif
16 8
17if LINUX 9if LINUX
18# All of these currently only work on GNU/Linux 10# All of these currently only work on GNU/Linux or W32
19 LINUX_DIR = $(EXIT) vpn $(PT) 11 LINUX_DIR = exit vpn pt
20endif 12endif
21if MINGW 13if MINGW
22 MINGW_DIR = vpn $(EXIT) 14 MINGW_DIR = vpn exit pt
23endif 15endif
24 16
25if HAVE_MYSQL 17if HAVE_MYSQL