aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
committerDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
commitea7eed529e12dcbed6a6775b818d8b93b9505f18 (patch)
tree521ba312e1268d1afb249db03c1b97d5a79181a1 /src/Makefile.am
parent48e50f64d8c05b2a6dab327156ea86fc92f171cf (diff)
downloadgnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.tar.gz
gnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.zip
Make building gnunet-testing lib optional.
This is all because emscripten doesn't have getaddrinfo.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 22b24b9bf..d3bd856e9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,8 +2,15 @@
2# INTLEMU_SUBDIRS = intlemu 2# INTLEMU_SUBDIRS = intlemu
3#endif 3#endif
4 4
5if HAVE_TESTING
6 TESTING = testing
7 TESTBED = testbed
8 CONSENSUS = consensus
9 EXPERIMENTATION = experimentation
10endif
11
5if HAVE_EXPERIMENTAL 12if HAVE_EXPERIMENTAL
6 EXP_DIR = gns set dv consensus experimentation 13 EXP_DIR = gns set dv $(CONSENSUS) $(EXPERIMENTATION)
7endif 14endif
8 15
9if LINUX 16if LINUX
@@ -31,7 +38,7 @@ SUBDIRS = \
31 block \ 38 block \
32 statistics \ 39 statistics \
33 arm \ 40 arm \
34 testing \ 41 $(TESTING) \
35 peerinfo \ 42 peerinfo \
36 $(MYSQL_DIR) \ 43 $(MYSQL_DIR) \
37 $(POSTGRES_DIR) \ 44 $(POSTGRES_DIR) \
@@ -46,7 +53,7 @@ SUBDIRS = \
46 ats-tool \ 53 ats-tool \
47 peerinfo-tool \ 54 peerinfo-tool \
48 core \ 55 core \
49 testbed \ 56 $(TESTBED) \
50 nse \ 57 nse \
51 dht \ 58 dht \
52 hostlist \ 59 hostlist \