aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-06-12 03:25:32 +0000
committerDavid Barksdale <amatus.amongus@gmail.com>2013-06-12 03:25:32 +0000
commitf12241a28dd9c0233316850c6082e2db25b155cc (patch)
tree44f30e6d167898f6276a201dbb647b5edecb3120 /src/Makefile.am
parent872f90748367b63368dba7ef3720b87ee495da6b (diff)
downloadgnunet-f12241a28dd9c0233316850c6082e2db25b155cc.tar.gz
gnunet-f12241a28dd9c0233316850c6082e2db25b155cc.zip
Make libidn optional.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2f4397dbe..bc8069614 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,16 +2,26 @@
2# INTLEMU_SUBDIRS = intlemu 2# INTLEMU_SUBDIRS = intlemu
3#endif 3#endif
4 4
5if HAVE_LIBIDN
6 DNS = dns
7 EXIT = exit
8 PT = pt
9else
10 DNS =
11 EXIT =
12 PT =
13endif
14
5if HAVE_EXPERIMENTAL 15if HAVE_EXPERIMENTAL
6 EXP_DIR = gns set dv consensus experimentation 16 EXP_DIR = gns set dv consensus experimentation
7endif 17endif
8 18
9if LINUX 19if LINUX
10# All of these currently only work on GNU/Linux 20# All of these currently only work on GNU/Linux
11 LINUX_DIR = dns exit vpn pt 21 LINUX_DIR = $(DNS) $(EXIT) vpn $(PT)
12endif 22endif
13if MINGW 23if MINGW
14 MINGW_DIR = dns vpn exit 24 MINGW_DIR = $(DNS) vpn $(EXIT)
15endif 25endif
16 26
17if HAVE_MYSQL 27if HAVE_MYSQL