aboutsummaryrefslogtreecommitdiff
path: root/src/arm/Makefile.am
diff options
context:
space:
mode:
authorSafey A.Halim <safey.allah@gmail.com>2010-01-15 15:24:30 +0000
committerSafey A.Halim <safey.allah@gmail.com>2010-01-15 15:24:30 +0000
commita257f028184102b04995c6774f065200919a3dff (patch)
treee0e2760dbab86c615447dc2923fc59a45bc2f098 /src/arm/Makefile.am
parent6cc0ff803561b9c05736781042811d73d75761b2 (diff)
downloadgnunet-a257f028184102b04995c6774f065200919a3dff.tar.gz
gnunet-a257f028184102b04995c6774f065200919a3dff.zip
Test case for arm exponential backoff (Incomplete)
Diffstat (limited to 'src/arm/Makefile.am')
-rw-r--r--src/arm/Makefile.am24
1 files changed, 19 insertions, 5 deletions
diff --git a/src/arm/Makefile.am b/src/arm/Makefile.am
index 4bfda1756..36161e8a0 100644
--- a/src/arm/Makefile.am
+++ b/src/arm/Makefile.am
@@ -23,7 +23,8 @@ libgnunetarm_la_LDFLAGS = \
23 23
24bin_PROGRAMS = \ 24bin_PROGRAMS = \
25 gnunet-arm \ 25 gnunet-arm \
26 gnunet-service-arm 26 gnunet-service-arm \
27 mockup-service
27 28
28gnunet_arm_SOURCES = \ 29gnunet_arm_SOURCES = \
29 gnunet-arm.c 30 gnunet-arm.c
@@ -39,13 +40,20 @@ gnunet_service_arm_LDADD = \
39 $(GN_LIBINTL) 40 $(GN_LIBINTL)
40 41
41 42
42check_PROGRAMS = \ 43mockup_service_SOURCES = \
43 test_arm_api 44 mockup-service.c
45 mockup_service_LDADD = \
46 $(top_builddir)/src/util/libgnunetutil.la
47
44 48
49check_PROGRAMS = \
50 test_arm_api \
51 test_exponential_backoff
52
45check_SCRIPTS = \ 53check_SCRIPTS = \
46 test_gnunet_arm.sh 54 test_gnunet_arm.sh
47 55
48TESTS = $(check_PROGRAMS) $(check_SCRIPTS) 56TESTS = test_arm_api $(check_SCRIPTS)
49 57
50test_arm_api_SOURCES = \ 58test_arm_api_SOURCES = \
51 test_arm_api.c 59 test_arm_api.c
@@ -53,6 +61,12 @@ test_arm_api_LDADD = \
53 $(top_builddir)/src/arm/libgnunetarm.la \ 61 $(top_builddir)/src/arm/libgnunetarm.la \
54 $(top_builddir)/src/util/libgnunetutil.la 62 $(top_builddir)/src/util/libgnunetutil.la
55 63
56 64test_exponential_backoff_SOURCES = \
65 test_exponential_backoff.c
66test_exponential_backoff_LDADD = \
67 $(top_builddir)/src/arm/libgnunetarm.la \
68 $(top_builddir)/src/util/libgnunetutil.la
69
70
57EXTRA_DIST = \ 71EXTRA_DIST = \
58 test_arm_api_data.conf 72 test_arm_api_data.conf