aboutsummaryrefslogtreecommitdiff
path: root/src/arm/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-07-09 19:39:27 +0000
committerChristian Grothoff <christian@grothoff.org>2012-07-09 19:39:27 +0000
commitb1d71c239212875ec2d44b4393687110a7c3870b (patch)
tree953c030c5137561c26f5c5024beb31db765f64a5 /src/arm/Makefile.am
parent8f9464256fc06a884bf589b4004262a0549d11b3 (diff)
downloadgnunet-b1d71c239212875ec2d44b4393687110a7c3870b.tar.gz
gnunet-b1d71c239212875ec2d44b4393687110a7c3870b.zip
-LRN: switching to py for arm test as well
Diffstat (limited to 'src/arm/Makefile.am')
-rw-r--r--src/arm/Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/src/arm/Makefile.am b/src/arm/Makefile.am
index 7da1e2c60..035681ba6 100644
--- a/src/arm/Makefile.am
+++ b/src/arm/Makefile.am
@@ -61,7 +61,7 @@ check_PROGRAMS = \
61 test_gnunet_service_manager 61 test_gnunet_service_manager
62 62
63check_SCRIPTS = \ 63check_SCRIPTS = \
64 test_gnunet_arm.sh 64 test_gnunet_arm.py
65 65
66if ENABLE_TEST_RUN 66if ENABLE_TEST_RUN
67TESTS = $(check_PROGRAMS) $(check_SCRIPTS) 67TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
@@ -85,7 +85,17 @@ test_gnunet_service_manager_SOURCES = \
85 $(top_builddir)/src/arm/libgnunetarm.la \ 85 $(top_builddir)/src/arm/libgnunetarm.la \
86 $(top_builddir)/src/util/libgnunetutil.la 86 $(top_builddir)/src/util/libgnunetutil.la
87 87
88do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
89
90%.py: %.py.in Makefile
91 $(do_subst) < $(srcdir)/$< > $@
92 chmod +x $@
93
94test_gnunet_arm.py: test_gnunet_arm.py.in Makefile
95 $(do_subst) < $(srcdir)/test_gnunet_arm.py.in > test_gnunet_arm.py
96 chmod +x test_gnunet_arm.py
97
88EXTRA_DIST = \ 98EXTRA_DIST = \
89 test_arm_api_data.conf \ 99 test_arm_api_data.conf \
90 do_start_process.c \ 100 test_gnunet_arm.py.in \
91 $(check_SCRIPTS) 101 do_start_process.c