aboutsummaryrefslogtreecommitdiff
path: root/src/arm/Makefile.am
diff options
context:
space:
mode:
authorSafey A.Halim <safey.allah@gmail.com>2010-05-10 11:33:03 +0000
committerSafey A.Halim <safey.allah@gmail.com>2010-05-10 11:33:03 +0000
commitbaecca71c8fca88ec3f9db55140861d3dddff9e9 (patch)
tree7bacdcd87f7bcd0692862e58769ce8473a7e375c /src/arm/Makefile.am
parent788afbc98ba0bbb1282582a8bd127e609f80d43e (diff)
downloadgnunet-baecca71c8fca88ec3f9db55140861d3dddff9e9.tar.gz
gnunet-baecca71c8fca88ec3f9db55140861d3dddff9e9.zip
gnunet service manager creates listening sockets for services having port fields in their configuration entries and runs those services whenever clients try to connect to them
Diffstat (limited to 'src/arm/Makefile.am')
-rw-r--r--src/arm/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/arm/Makefile.am b/src/arm/Makefile.am
index d6b6d2788..92c0fdc34 100644
--- a/src/arm/Makefile.am
+++ b/src/arm/Makefile.am
@@ -34,7 +34,8 @@ gnunet_arm_LDADD = \
34 $(GN_LIBINTL) 34 $(GN_LIBINTL)
35 35
36gnunet_service_arm_SOURCES = \ 36gnunet_service_arm_SOURCES = \
37 gnunet-service-arm.c 37 gnunet-service-arm.c gnunet_service_arm_.h \
38 gnunet-service-manager.c
38gnunet_service_arm_LDADD = \ 39gnunet_service_arm_LDADD = \
39 $(top_builddir)/src/util/libgnunetutil.la \ 40 $(top_builddir)/src/util/libgnunetutil.la \
40 $(GN_LIBINTL) 41 $(GN_LIBINTL)
@@ -48,7 +49,8 @@ mockup_service_SOURCES = \
48 49
49check_PROGRAMS = \ 50check_PROGRAMS = \
50 test_arm_api \ 51 test_arm_api \
51 test_exponential_backoff 52 test_exponential_backoff \
53 test_gnunet_service_manager
52 54
53check_SCRIPTS = \ 55check_SCRIPTS = \
54 test_gnunet_arm.sh 56 test_gnunet_arm.sh
@@ -67,6 +69,12 @@ test_exponential_backoff_LDADD = \
67 $(top_builddir)/src/arm/libgnunetarm.la \ 69 $(top_builddir)/src/arm/libgnunetarm.la \
68 $(top_builddir)/src/util/libgnunetutil.la 70 $(top_builddir)/src/util/libgnunetutil.la
69 71
72test_gnunet_service_manager_SOURCES = \
73 test_gnunet_service_manager.c
74 test_gnunet_service_manager_LDADD = \
75 $(top_builddir)/src/arm/libgnunetarm.la \
76 $(top_builddir)/src/util/libgnunetutil.la
77
70EXTRA_DIST = \ 78EXTRA_DIST = \
71 test_arm_api_data.conf \ 79 test_arm_api_data.conf \
72 do_start_process.c \ 80 do_start_process.c \