aboutsummaryrefslogtreecommitdiff
path: root/src/ats-tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-09-10 08:54:30 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-09-10 08:54:30 +0000
commit7ff2687a523b15f9483bec521ebf7f89e0690e3a (patch)
treec6e05c1f3ce3cc8b94ab2141b084188ee02ad2ad /src/ats-tests/Makefile.am
parentf363035eff30aa7e28ce2f561b7d7fd89a19f97f (diff)
downloadgnunet-7ff2687a523b15f9483bec521ebf7f89e0690e3a.tar.gz
gnunet-7ff2687a523b15f9483bec521ebf7f89e0690e3a.zip
updated configuration files
Diffstat (limited to 'src/ats-tests/Makefile.am')
-rw-r--r--src/ats-tests/Makefile.am48
1 files changed, 45 insertions, 3 deletions
diff --git a/src/ats-tests/Makefile.am b/src/ats-tests/Makefile.am
index 79010f06d..3285143aa 100644
--- a/src/ats-tests/Makefile.am
+++ b/src/ats-tests/Makefile.am
@@ -13,13 +13,17 @@ if USE_COVERAGE
13endif 13endif
14 14
15if HAVE_LIBGLPK 15if HAVE_LIBGLPK
16 16 PERF_MLP_BANDWIDTH = perf_ats_mlp_bandwidth
17 PERF_MLP_DELAY = perf_ats_mlp_delay
17endif 18endif
18 19
19if HAVE_TESTING 20if HAVE_TESTING
20TESTING_TESTS = \ 21TESTING_TESTS = \
21 perf_ats_proportional_bandwidth \ 22 perf_ats_proportional_bandwidth \
22 perf_ats_proportional_delay 23 perf_ats_proportional_delay \
24 perf_ats_ril_bandwidth \
25 perf_ats_ril_delay \
26 $(PERF_MLP_BANDWIDTH) $(PERF_MLP_DELAY)
23endif 27endif
24 28
25check_PROGRAMS = \ 29check_PROGRAMS = \
@@ -44,7 +48,45 @@ perf_ats_proportional_delay_LDADD = \
44 $(top_builddir)/src/testbed/libgnunettestbed.la \ 48 $(top_builddir)/src/testbed/libgnunettestbed.la \
45 $(top_builddir)/src/ats/libgnunetats.la \ 49 $(top_builddir)/src/ats/libgnunetats.la \
46 $(top_builddir)/src/core/libgnunetcore.la 50 $(top_builddir)/src/core/libgnunetcore.la
51
52if HAVE_LIBGLPK
53perf_ats_mlp_bandwidth_SOURCES = \
54 perf_ats.c
55perf_ats_mlp_bandwidth_LDADD = \
56 $(top_builddir)/src/util/libgnunetutil.la \
57 $(top_builddir)/src/testbed/libgnunettestbed.la \
58 $(top_builddir)/src/ats/libgnunetats.la \
59 $(top_builddir)/src/core/libgnunetcore.la
60
61perf_ats_mlp_delay_SOURCES = \
62 perf_ats.c
63perf_ats_mlp_delay_LDADD = \
64 $(top_builddir)/src/util/libgnunetutil.la \
65 $(top_builddir)/src/testbed/libgnunettestbed.la \
66 $(top_builddir)/src/ats/libgnunetats.la \
67 $(top_builddir)/src/core/libgnunetcore.la
68endif
69
70perf_ats_ril_bandwidth_SOURCES = \
71 perf_ats.c
72perf_ats_ril_bandwidth_LDADD = \
73 $(top_builddir)/src/util/libgnunetutil.la \
74 $(top_builddir)/src/testbed/libgnunettestbed.la \
75 $(top_builddir)/src/ats/libgnunetats.la \
76 $(top_builddir)/src/core/libgnunetcore.la
77
78perf_ats_ril_delay_SOURCES = \
79 perf_ats.c
80perf_ats_ril_delay_LDADD = \
81 $(top_builddir)/src/util/libgnunetutil.la \
82 $(top_builddir)/src/testbed/libgnunettestbed.la \
83 $(top_builddir)/src/ats/libgnunetats.la \
84 $(top_builddir)/src/core/libgnunetcore.la
47 85
48EXTRA_DIST = \ 86EXTRA_DIST = \
49 perf_ats_proportional_bandwidth.conf \ 87 perf_ats_proportional_bandwidth.conf \
50 perf_ats_proportional_delay.conf 88 perf_ats_proportional_delay.conf \
89 perf_ats_mlp_bandwidth.conf \
90 perf_ats_mlp_delay.conf \
91 perf_ats_ril_bandwidth.conf \
92 perf_ats_ril_delay.conf