aboutsummaryrefslogtreecommitdiff
path: root/src/ats-tool/meson.build
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-09-29 17:38:35 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-09-29 17:38:35 +0200
commit0830b2cca764101efa3920dd2ab1a4d2f3a3e187 (patch)
treef9ab7f6eb315aa26efee16bc427f76b2b81498dc /src/ats-tool/meson.build
parent30471f2e14e828c584a1977c7478628f1d2a0879 (diff)
downloadgnunet-0830b2cca764101efa3920dd2ab1a4d2f3a3e187.tar.gz
gnunet-0830b2cca764101efa3920dd2ab1a4d2f3a3e187.zip
BUILD: Add ats tool for now; fix installation of files
Diffstat (limited to 'src/ats-tool/meson.build')
-rw-r--r--src/ats-tool/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/ats-tool/meson.build b/src/ats-tool/meson.build
new file mode 100644
index 000000000..6b6df7b3d
--- /dev/null
+++ b/src/ats-tool/meson.build
@@ -0,0 +1,15 @@
1if get_option('monolith')
2 subdir_done()
3endif
4
5executable ('gnunet-ats',
6 ['gnunet-ats.c'],
7 dependencies: [libgnunetats_dep, libgnunetutil_dep,
8 libgnunettransport_dep,
9 libgnunetnt_dep,
10 libgnunethello_dep
11 ],
12 include_directories: [incdir, configuration_inc],
13 install: true,
14 install_dir: get_option('bindir'))
15