aboutsummaryrefslogtreecommitdiff
path: root/src/ats/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-09-26 13:55:43 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-09-26 13:55:43 +0000
commit709d0b15f2fdd099a4715460ec6aea2622595406 (patch)
tree5e510f202ed01b8be949cd51f29672433fa9f211 /src/ats/Makefile.am
parent6a187e4628ecd1879564e85dee30d5284b8eb678 (diff)
downloadgnunet-709d0b15f2fdd099a4715460ec6aea2622595406.tar.gz
gnunet-709d0b15f2fdd099a4715460ec6aea2622595406.zip
addign test
Diffstat (limited to 'src/ats/Makefile.am')
-rw-r--r--src/ats/Makefile.am39
1 files changed, 38 insertions, 1 deletions
diff --git a/src/ats/Makefile.am b/src/ats/Makefile.am
index 4f2536dea..feb768cb5 100644
--- a/src/ats/Makefile.am
+++ b/src/ats/Makefile.am
@@ -26,6 +26,8 @@ if HAVE_LIBGLPK
26 GN_MLP_ADD_REQUEST_ADDRESS = test_ats_solver_add_address_and_request_mlp 26 GN_MLP_ADD_REQUEST_ADDRESS = test_ats_solver_add_address_and_request_mlp
27 GN_MLP_REQUEST_ADD_ADDRESS = test_ats_solver_request_and_add_address_mlp 27 GN_MLP_REQUEST_ADD_ADDRESS = test_ats_solver_request_and_add_address_mlp
28 GN_MLP_REQUEST_DELETE_ADDRESS = test_ats_solver_request_and_delete_address_mlp 28 GN_MLP_REQUEST_DELETE_ADDRESS = test_ats_solver_request_and_delete_address_mlp
29 GN_MLP_ALTERNATIVE_DELETE_ADDRESS = test_ats_solver_alternative_after_delete_address_mlp
30
29endif 31endif
30 32
31lib_LTLIBRARIES = libgnunetats.la 33lib_LTLIBRARIES = libgnunetats.la
@@ -91,7 +93,10 @@ TESTING_TESTS = \
91 test_ats_solver_request_and_add_address_ril \ 93 test_ats_solver_request_and_add_address_ril \
92 test_ats_solver_request_and_delete_address_proportional \ 94 test_ats_solver_request_and_delete_address_proportional \
93 $(GN_MLP_REQUEST_DELETE_ADDRESS) \ 95 $(GN_MLP_REQUEST_DELETE_ADDRESS) \
94 test_ats_solver_request_and_delete_address_ril 96 test_ats_solver_request_and_delete_address_ril \
97 test_ats_solver_alternative_after_delete_address_proportional \
98 $(GN_MLP_ALTERNATIVE_DELETE_ADDRESS) \
99 test_ats_solver_alternative_after_delete_address_ril
95# test_ats_api_scheduling_min_bw 100# test_ats_api_scheduling_min_bw
96# test_ats_api_scheduling_check_min_bw_alt 101# test_ats_api_scheduling_check_min_bw_alt
97# test_ats_api_scheduling_update_address 102# test_ats_api_scheduling_update_address
@@ -366,6 +371,38 @@ test_ats_solver_request_and_delete_address_ril_LDADD = \
366 $(top_builddir)/src/statistics/libgnunetstatistics.la 371 $(top_builddir)/src/statistics/libgnunetstatistics.la
367 372
368 373
374test_ats_solver_alternative_after_delete_address_proportional_SOURCES = \
375 test_ats_solver_alternative_after_delete_address.c \
376 test_ats_api_common.c test_ats_api_common.h
377test_ats_solver_alternative_after_delete_address_proportional_LDADD = \
378 $(top_builddir)/src/util/libgnunetutil.la \
379 $(top_builddir)/src/testing/libgnunettesting.la \
380 $(top_builddir)/src/hello/libgnunethello.la \
381 $(top_builddir)/src/ats/libgnunetats.la \
382 $(top_builddir)/src/statistics/libgnunetstatistics.la
383
384if HAVE_LIBGLPK
385test_ats_solver_alternative_after_delete_address_mlp_SOURCES = \
386 test_ats_solver_alternative_after_delete_address.c \
387 test_ats_api_common.c test_ats_api_common.h
388test_ats_solver_alternative_after_delete_address_mlp_LDADD = \
389 $(top_builddir)/src/util/libgnunetutil.la \
390 $(top_builddir)/src/testing/libgnunettesting.la \
391 $(top_builddir)/src/hello/libgnunethello.la \
392 $(top_builddir)/src/ats/libgnunetats.la \
393 $(top_builddir)/src/statistics/libgnunetstatistics.la
394endif
395
396test_ats_solver_alternative_after_delete_address_ril_SOURCES = \
397 test_ats_solver_alternative_after_delete_address.c \
398 test_ats_api_common.c test_ats_api_common.h
399test_ats_solver_alternative_after_delete_address_ril_LDADD = \
400 $(top_builddir)/src/util/libgnunetutil.la \
401 $(top_builddir)/src/testing/libgnunettesting.la \
402 $(top_builddir)/src/hello/libgnunethello.la \
403 $(top_builddir)/src/ats/libgnunetats.la \
404 $(top_builddir)/src/statistics/libgnunetstatistics.la
405
369 406
370#test_ats_api_scheduling_min_bw_SOURCES = \ 407#test_ats_api_scheduling_min_bw_SOURCES = \
371# test_ats_api_scheduling_min_bw.c test_ats_api_common.c 408# test_ats_api_scheduling_min_bw.c test_ats_api_common.c