aboutsummaryrefslogtreecommitdiff
path: root/src/ats/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-08-05 12:49:28 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-08-05 12:49:28 +0000
commit72947853f7e945a53b8d8902b0caaaf5f2f8c98a (patch)
treec6a9bfd5188883ec42067f04d824559779325839 /src/ats/Makefile.am
parent6311b1d73410f4a95c1fa634de11e1b22019e38d (diff)
downloadgnunet-72947853f7e945a53b8d8902b0caaaf5f2f8c98a.tar.gz
gnunet-72947853f7e945a53b8d8902b0caaaf5f2f8c98a.zip
basics for generic ats benchmark
Diffstat (limited to 'src/ats/Makefile.am')
-rw-r--r--src/ats/Makefile.am32
1 files changed, 15 insertions, 17 deletions
diff --git a/src/ats/Makefile.am b/src/ats/Makefile.am
index f9aca59b6..1d9a11518 100644
--- a/src/ats/Makefile.am
+++ b/src/ats/Makefile.am
@@ -78,10 +78,9 @@ TESTING_TESTS = \
78 test_ats_simplistic_switch_networks \ 78 test_ats_simplistic_switch_networks \
79 test_ats_simplistic_change_preference \ 79 test_ats_simplistic_change_preference \
80 test_ats_api_performance_list_addresses \ 80 test_ats_api_performance_list_addresses \
81 test_ats_api_performance_address_info 81 test_ats_api_performance_address_info \
82# test_ats_api_scheduling_get_type 82 perf_ats_simplistic_bandwidth \
83# test_ats_api_bandwidth_consumption 83 perf_ats_simplistic_delay
84# test_ats_simplistic_pref_aging
85endif 84endif
86 85
87check_PROGRAMS = \ 86check_PROGRAMS = \
@@ -229,7 +228,6 @@ test_ats_mlp_update_LDADD = \
229 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 228 $(top_builddir)/src/statistics/libgnunetstatistics.la \
230 $(top_builddir)/src/ats/libgnunetats.la 229 $(top_builddir)/src/ats/libgnunetats.la
231 230
232
233perf_ats_mlp_SOURCES = \ 231perf_ats_mlp_SOURCES = \
234 $(GN_MLP_SRC) perf_ats_mlp.c test_ats_api_common.c gnunet-service-ats_normalization.c 232 $(GN_MLP_SRC) perf_ats_mlp.c test_ats_api_common.c gnunet-service-ats_normalization.c
235perf_ats_mlp_LDADD = \ 233perf_ats_mlp_LDADD = \
@@ -248,20 +246,20 @@ test_ats_normalization_update_quality_LDADD = \
248 $(top_builddir)/src/testing/libgnunettesting.la \ 246 $(top_builddir)/src/testing/libgnunettesting.la \
249 $(top_builddir)/src/ats/libgnunetats.la 247 $(top_builddir)/src/ats/libgnunetats.la
250 248
251#test_ats_mlp_averaging_SOURCES = \ 249# performance tests
252# $(GN_MLP_SRC) test_ats_mlp_averaging.c test_ats_api_common.c
253#test_ats_mlp_averaging_LDADD = \
254# $(GN_LIBGLPK) \
255# $(top_builddir)/src/util/libgnunetutil.la \
256# $(top_builddir)/src/statistics/libgnunetstatistics.la
257 250
258#test_ats_api_bandwidth_consumption_SOURCES = \ 251perf_ats_simplistic_bandwidth_SOURCES = \
259# test_ats_api_bandwidth_consumption.c 252 perf_ats.c
260#test_ats_api_bandwidth_consumption_LDADD = \ 253perf_ats_simplistic_bandwidth_LDADD = \
261# $(top_builddir)/src/util/libgnunetutil.la \ 254 $(top_builddir)/src/util/libgnunetutil.la \
262# $(top_builddir)/src/testing/libgnunettesting.la \ 255 $(top_builddir)/src/ats/libgnunetats.la
263# $(top_builddir)/src/ats/libgnunetats.la
264 256
257perf_ats_simplistic_delay_SOURCES = \
258 perf_ats.c
259perf_ats_simplistic_delay_LDADD = \
260 $(top_builddir)/src/util/libgnunetutil.la \
261 $(top_builddir)/src/ats/libgnunetats.la
262
265 263
266EXTRA_DIST = \ 264EXTRA_DIST = \
267 ats.h \ 265 ats.h \