aboutsummaryrefslogtreecommitdiff
path: root/src/consensus/Makefile.am
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2017-02-26 23:05:29 +0100
committerFlorian Dold <florian.dold@gmail.com>2017-02-26 23:06:05 +0100
commite2b2ab728217a64027232c7b8fbbb68ba13edd4a (patch)
tree69caa7c21703f2eabe9a1ec12ef7d07ac58b0728 /src/consensus/Makefile.am
parent8d7c29c4684f807d5e9a3004bbbab132b158c5aa (diff)
downloadgnunet-e2b2ab728217a64027232c7b8fbbb68ba13edd4a.tar.gz
gnunet-e2b2ab728217a64027232c7b8fbbb68ba13edd4a.zip
wrap consensus elements in block type
Diffstat (limited to 'src/consensus/Makefile.am')
-rw-r--r--src/consensus/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/consensus/Makefile.am b/src/consensus/Makefile.am
index b6385ac71..2b1987fbc 100644
--- a/src/consensus/Makefile.am
+++ b/src/consensus/Makefile.am
@@ -5,6 +5,8 @@ pkgcfgdir= $(pkgdatadir)/config.d/
5 5
6libexecdir= $(pkglibdir)/libexec/ 6libexecdir= $(pkglibdir)/libexec/
7 7
8plugindir = $(libdir)/gnunet
9
8pkgcfg_DATA = \ 10pkgcfg_DATA = \
9 consensus.conf 11 consensus.conf
10 12
@@ -67,6 +69,22 @@ libgnunetconsensus_la_LIBADD = \
67libgnunetconsensus_la_LDFLAGS = \ 69libgnunetconsensus_la_LDFLAGS = \
68 $(GN_LIB_LDFLAGS) 70 $(GN_LIB_LDFLAGS)
69 71
72
73plugin_LTLIBRARIES = \
74 libgnunet_plugin_block_consensus.la
75
76libgnunet_plugin_block_consensus_la_SOURCES = \
77 plugin_block_consensus.c
78libgnunet_plugin_block_consensus_la_LIBADD = \
79 $(top_builddir)/src/block/libgnunetblock.la \
80 $(top_builddir)/src/block/libgnunetblockgroup.la \
81 $(top_builddir)/src/util/libgnunetutil.la \
82 $(LTLIBINTL)
83libgnunet_plugin_block_consensus_la_LDFLAGS = \
84 $(GN_PLUGIN_LDFLAGS)
85
86
87
70if HAVE_TESTING 88if HAVE_TESTING
71check_PROGRAMS = \ 89check_PROGRAMS = \
72 test_consensus_api 90 test_consensus_api