aboutsummaryrefslogtreecommitdiff
path: root/src/conversation/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-16 11:34:10 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-16 11:34:10 +0000
commitb6bfed8309e6b9b3286b8f608ad899bfb0a97205 (patch)
tree46cadaba7deadf7cb07dcc0b3d07f28fc147ffc2 /src/conversation/Makefile.am
parent5ad45d439b900ea388b93aca8547ad03c53ddc68 (diff)
downloadgnunet-b6bfed8309e6b9b3286b8f608ad899bfb0a97205.tar.gz
gnunet-b6bfed8309e6b9b3286b8f608ad899bfb0a97205.zip
-moving code to new libgnunetgnsrecord in preparation for addressing #3052
Diffstat (limited to 'src/conversation/Makefile.am')
-rw-r--r--src/conversation/Makefile.am39
1 files changed, 20 insertions, 19 deletions
diff --git a/src/conversation/Makefile.am b/src/conversation/Makefile.am
index bb2b3d77d..5e4ad0d67 100644
--- a/src/conversation/Makefile.am
+++ b/src/conversation/Makefile.am
@@ -17,7 +17,7 @@ pkgcfgdir= $(prefix)/share/gnunet/config.d/
17libexecdir= $(prefix)/lib/gnunet/libexec/ 17libexecdir= $(prefix)/lib/gnunet/libexec/
18 18
19libgnunetmicrophone_la_SOURCES = \ 19libgnunetmicrophone_la_SOURCES = \
20 microphone.c 20 microphone.c
21libgnunetmicrophone_la_LIBADD = \ 21libgnunetmicrophone_la_LIBADD = \
22 $(top_builddir)/src/util/libgnunetutil.la 22 $(top_builddir)/src/util/libgnunetutil.la
23libgnunetmicrophone_la_LDFLAGS = \ 23libgnunetmicrophone_la_LDFLAGS = \
@@ -25,7 +25,7 @@ libgnunetmicrophone_la_LDFLAGS = \
25 -version-info 0:0:0 25 -version-info 0:0:0
26 26
27libgnunetspeaker_la_SOURCES = \ 27libgnunetspeaker_la_SOURCES = \
28 speaker.c 28 speaker.c
29libgnunetspeaker_la_LIBADD = \ 29libgnunetspeaker_la_LIBADD = \
30 $(top_builddir)/src/util/libgnunetutil.la 30 $(top_builddir)/src/util/libgnunetutil.la
31libgnunetspeaker_la_LDFLAGS = \ 31libgnunetspeaker_la_LDFLAGS = \
@@ -34,12 +34,12 @@ libgnunetspeaker_la_LDFLAGS = \
34 34
35 35
36libgnunetconversation_la_SOURCES = \ 36libgnunetconversation_la_SOURCES = \
37 conversation_api.c 37 conversation_api.c
38libgnunetconversation_la_LIBADD = \ 38libgnunetconversation_la_LIBADD = \
39 $(top_builddir)/src/gns/libgnunetgns.la \ 39 $(top_builddir)/src/gns/libgnunetgns.la \
40 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 40 $(top_builddir)/src/namestore/libgnunetnamestore.la \
41 $(top_builddir)/src/identity/libgnunetidentity.la \ 41 $(top_builddir)/src/identity/libgnunetidentity.la \
42 $(top_builddir)/src/util/libgnunetutil.la 42 $(top_builddir)/src/util/libgnunetutil.la
43 43
44libgnunetconversation_la_LDFLAGS = \ 44libgnunetconversation_la_LDFLAGS = \
45 $(GNUNET_LDFLAGS) $(WINFLAGS) \ 45 $(GNUNET_LDFLAGS) $(WINFLAGS) \
@@ -48,10 +48,10 @@ libgnunetconversation_la_LDFLAGS = \
48 48
49bin_PROGRAMS = \ 49bin_PROGRAMS = \
50 gnunet-conversation-test \ 50 gnunet-conversation-test \
51 gnunet-conversation 51 gnunet-conversation
52 52
53libexec_PROGRAMS = \ 53libexec_PROGRAMS = \
54 gnunet-service-conversation 54 gnunet-service-conversation
55 55
56if HAVE_PULSE 56if HAVE_PULSE
57if HAVE_OPUS 57if HAVE_OPUS
@@ -64,7 +64,7 @@ endif
64 64
65 65
66check_PROGRAMS = \ 66check_PROGRAMS = \
67 test_conversation_api 67 test_conversation_api
68 68
69TESTS = $(check_PROGRAMS) 69TESTS = $(check_PROGRAMS)
70 70
@@ -74,18 +74,18 @@ gnunet_helper_audio_record_SOURCES = \
74gnunet_helper_audio_record_LDADD = \ 74gnunet_helper_audio_record_LDADD = \
75 $(top_builddir)/src/util/libgnunetutil.la \ 75 $(top_builddir)/src/util/libgnunetutil.la \
76 -lpulse -lopus\ 76 -lpulse -lopus\
77 $(INTLLIBS) 77 $(INTLLIBS)
78gnunet_helper_audio_record_LDFLAGS = \ 78gnunet_helper_audio_record_LDFLAGS = \
79 $(GNUNET_LDFLAGS) $(WINFLAGS) 79 $(GNUNET_LDFLAGS) $(WINFLAGS)
80 80
81gnunet_helper_audio_playback_SOURCES = \ 81gnunet_helper_audio_playback_SOURCES = \
82 gnunet-helper-audio-playback.c 82 gnunet-helper-audio-playback.c
83gnunet_helper_audio_playback_LDADD = \ 83gnunet_helper_audio_playback_LDADD = \
84 $(top_builddir)/src/util/libgnunetutil.la \ 84 $(top_builddir)/src/util/libgnunetutil.la \
85 -lpulse -lopus\ 85 -lpulse -lopus\
86 $(INTLLIBS) 86 $(INTLLIBS)
87gnunet_helper_audio_playback_LDFLAGS = \ 87gnunet_helper_audio_playback_LDFLAGS = \
88 $(GNUNET_LDFLAGS) $(WINFLAGS) 88 $(GNUNET_LDFLAGS) $(WINFLAGS)
89 89
90gnunet_service_conversation_SOURCES = \ 90gnunet_service_conversation_SOURCES = \
91 gnunet-service-conversation.c 91 gnunet-service-conversation.c
@@ -95,9 +95,9 @@ gnunet_service_conversation_LDADD = \
95 libgnunetmicrophone.la \ 95 libgnunetmicrophone.la \
96 $(top_builddir)/src/mesh/libgnunetmesh.la \ 96 $(top_builddir)/src/mesh/libgnunetmesh.la \
97 $(top_builddir)/src/util/libgnunetutil.la \ 97 $(top_builddir)/src/util/libgnunetutil.la \
98 $(INTLLIBS) 98 $(INTLLIBS)
99gnunet_service_conversation_LDFLAGS = \ 99gnunet_service_conversation_LDFLAGS = \
100 $(GNUNET_LDFLAGS) $(WINFLAGS) 100 $(GNUNET_LDFLAGS) $(WINFLAGS)
101 101
102gnunet_conversation_SOURCES = \ 102gnunet_conversation_SOURCES = \
103 gnunet-conversation.c 103 gnunet-conversation.c
@@ -106,12 +106,13 @@ gnunet_conversation_LDADD = \
106 libgnunetspeaker.la \ 106 libgnunetspeaker.la \
107 libgnunetconversation.la \ 107 libgnunetconversation.la \
108 $(top_builddir)/src/gns/libgnunetgns.la \ 108 $(top_builddir)/src/gns/libgnunetgns.la \
109 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
109 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 110 $(top_builddir)/src/namestore/libgnunetnamestore.la \
110 $(top_builddir)/src/identity/libgnunetidentity.la \ 111 $(top_builddir)/src/identity/libgnunetidentity.la \
111 $(top_builddir)/src/util/libgnunetutil.la \ 112 $(top_builddir)/src/util/libgnunetutil.la \
112 $(INTLLIBS) 113 $(INTLLIBS)
113gnunet_conversation_LDFLAGS = \ 114gnunet_conversation_LDFLAGS = \
114 $(GNUNET_LDFLAGS) $(WINFLAGS) 115 $(GNUNET_LDFLAGS) $(WINFLAGS)
115 116
116gnunet_conversation_test_SOURCES = \ 117gnunet_conversation_test_SOURCES = \
117 gnunet-conversation-test.c 118 gnunet-conversation-test.c
@@ -119,17 +120,17 @@ gnunet_conversation_test_LDADD = \
119 libgnunetmicrophone.la \ 120 libgnunetmicrophone.la \
120 libgnunetspeaker.la \ 121 libgnunetspeaker.la \
121 $(top_builddir)/src/util/libgnunetutil.la \ 122 $(top_builddir)/src/util/libgnunetutil.la \
122 $(INTLLIBS) 123 $(INTLLIBS)
123gnunet_conversation_test_LDFLAGS = \ 124gnunet_conversation_test_LDFLAGS = \
124 $(GNUNET_LDFLAGS) $(WINFLAGS) 125 $(GNUNET_LDFLAGS) $(WINFLAGS)
125 126
126 127
127test_conversation_api_SOURCES = \ 128test_conversation_api_SOURCES = \
128 test_conversation_api.c 129 test_conversation_api.c
129test_conversation_api_LDADD = \ 130test_conversation_api_LDADD = \
130 libgnunetconversation.la \ 131 libgnunetconversation.la \
131 $(top_builddir)/src/util/libgnunetutil.la 132 $(top_builddir)/src/util/libgnunetutil.la
132test_conversation_api_LDFLAGS = \ 133test_conversation_api_LDFLAGS = \
133 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic 134 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic
134 135
135 pkgcfg_DATA = conversation.conf 136 pkgcfg_DATA = conversation.conf