aboutsummaryrefslogtreecommitdiff
path: root/src/conversation/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-02 19:48:12 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-02 19:48:12 +0000
commite4d1ce975f6bbb5c89904ad9c174f1e29b49a76b (patch)
tree70d3e98b1386acc4c218c973b44d62691fd49f1f /src/conversation/Makefile.am
parente4eafbbef9d494182ca863f7ee03095a235bdf71 (diff)
downloadgnunet-e4d1ce975f6bbb5c89904ad9c174f1e29b49a76b.tar.gz
gnunet-e4d1ce975f6bbb5c89904ad9c174f1e29b49a76b.zip
-implement speaker library
Diffstat (limited to 'src/conversation/Makefile.am')
-rw-r--r--src/conversation/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/conversation/Makefile.am b/src/conversation/Makefile.am
index ac2f47612..10fd26014 100644
--- a/src/conversation/Makefile.am
+++ b/src/conversation/Makefile.am
@@ -16,6 +16,7 @@ AM_CPPFLAGS = \
16 16
17lib_LTLIBRARIES = \ 17lib_LTLIBRARIES = \
18 libgnunetmicrophone.la \ 18 libgnunetmicrophone.la \
19 libgnunetspeaker.la \
19 libgnunetconversation.la 20 libgnunetconversation.la
20 21
21pkgcfgdir= $(prefix)/share/gnunet/config.d/ 22pkgcfgdir= $(prefix)/share/gnunet/config.d/
@@ -30,12 +31,21 @@ libgnunetmicrophone_la_LDFLAGS = \
30 $(GNUNET_LDFLAGS) $(WINFLAGS) \ 31 $(GNUNET_LDFLAGS) $(WINFLAGS) \
31 -version-info 0:0:0 32 -version-info 0:0:0
32 33
34libgnunetspeaker_la_SOURCES = \
35 speaker.c
36libgnunetspeaker_la_LIBADD = \
37 -lgnunetutil
38libgnunetspeaker_la_LDFLAGS = \
39 $(GNUNET_LDFLAGS) $(WINFLAGS) \
40 -version-info 0:0:0
41
33 42
34libgnunetconversation_la_SOURCES = \ 43libgnunetconversation_la_SOURCES = \
35 conversation_api.c \ 44 conversation_api.c \
36 conversation_api2.c 45 conversation_api2.c
37libgnunetconversation_la_LIBADD = \ 46libgnunetconversation_la_LIBADD = \
38 libgnunetmicrophone.la \ 47 libgnunetmicrophone.la \
48 libgnunetspeaker.la \
39 $(top_builddir)/src/gns/libgnunetgns.la \ 49 $(top_builddir)/src/gns/libgnunetgns.la \
40 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 50 $(top_builddir)/src/namestore/libgnunetnamestore.la \
41 $(top_builddir)/src/util/libgnunetutil.la 51 $(top_builddir)/src/util/libgnunetutil.la