aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2023-10-02 18:10:36 +0200
committert3sserakt <t3ss@posteo.de>2023-10-02 18:10:36 +0200
commit1016d6d193b1af38f90999de25854593c77364a8 (patch)
tree0eb47530e45cc7b046c672b4c6b8fa76778db35a /src/core/Makefile.am
parent02a1fdad33c37bf39d4bdbe4c535fcf4c6ed0cc4 (diff)
downloadgnunet-1016d6d193b1af38f90999de25854593c77364a8.tar.gz
gnunet-1016d6d193b1af38f90999de25854593c77364a8.zip
NEWS: Code moved to the core package to get rid of circular dependencies.
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am90
1 files changed, 45 insertions, 45 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index cad234abd..1343fe395 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -3,6 +3,8 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
3 3
4pkgcfgdir= $(pkgdatadir)/config.d/ 4pkgcfgdir= $(pkgdatadir)/config.d/
5 5
6plugindir = $(libdir)/gnunet
7
6libexecdir= $(pkglibdir)/libexec/ 8libexecdir= $(pkglibdir)/libexec/
7 9
8pkgcfg_DATA = \ 10pkgcfg_DATA = \
@@ -13,9 +15,15 @@ if USE_COVERAGE
13 XLIB = -lgcov 15 XLIB = -lgcov
14endif 16endif
15 17
18plugin_LTLIBRARIES = \
19 libgnunet_test_core_plugin_cmd_just_run.la
20
21TESTING_LIBS = \
22 libgnunetcoretesting.la
16 23
17lib_LTLIBRARIES = \ 24lib_LTLIBRARIES = \
18 libgnunetcore.la 25 libgnunetcore.la \
26 $(TESTING_LIBS)
19 27
20libgnunetcore_la_SOURCES = \ 28libgnunetcore_la_SOURCES = \
21 core_api.c core.h \ 29 core_api.c core.h \
@@ -27,6 +35,35 @@ libgnunetcore_la_LDFLAGS = \
27 $(GN_LIB_LDFLAGS) \ 35 $(GN_LIB_LDFLAGS) \
28 -version-info 0:1:0 36 -version-info 0:1:0
29 37
38libgnunet_test_core_plugin_cmd_just_run_la_SOURCES = \
39 test_core_plugin_cmd_just_run.c
40libgnunet_test_core_plugin_cmd_just_run_la_LIBADD = \
41 $(top_builddir)/src/transport/libgnunettransportapplication.la \
42 $(top_builddir)/src/transport/libgnunettransportcore.la \
43 $(top_builddir)/src/testing/libgnunettesting.la \
44 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
45 $(top_builddir)/src/core/libgnunetcoretesting.la \
46 $(top_builddir)/src/statistics/libgnunetstatistics.la \
47 $(top_builddir)/src/hello/libgnunethello.la \
48 $(top_builddir)/src/ats/libgnunetats.la \
49 $(top_builddir)/src/arm/libgnunetarm.la \
50 $(top_builddir)/src/util/libgnunetutil.la \
51 $(LTLIBINTL)
52libgnunet_test_core_plugin_cmd_just_run_la_LDFLAGS = \
53 $(GN_PLUGIN_LDFLAGS)
54
55libgnunetcoretesting_la_SOURCES = \
56 core_api_cmd_connecting_peers.c
57libgnunetcoretesting_la_LIBADD = \
58 $(top_builddir)/src/testing/libgnunettesting.la \
59 $(top_builddir)/src/transport/libgnunettransportapplication.la \
60 $(top_builddir)/src/transport/libgnunettransportcore.la \
61 $(top_builddir)/src/util/libgnunetutil.la
62libgnunetcoretesting_la_LDFLAGS = \
63 $(GN_LIBINTL) \
64 $(GN_LIB_LDFLAGS) \
65 -version-info 0:0:0
66
30 67
31libexec_PROGRAMS = \ 68libexec_PROGRAMS = \
32 gnunet-service-core 69 gnunet-service-core
@@ -60,32 +97,18 @@ TESTING_TESTS = \
60 97
61check_PROGRAMS = \ 98check_PROGRAMS = \
62 test_core_api_start_only \ 99 test_core_api_start_only \
63 test_core_api \
64 test_core_api_reliability \
65 test_core_quota_compliance_symmetric \
66 test_core_quota_compliance_asymmetric_send_limited \
67 test_core_quota_compliance_asymmetric_recv_limited \
68 $(TESTING_TESTS) 100 $(TESTING_TESTS)
69 101
102# Only test TNG if we run experimental
103check_SCRIPTS= \
104 test_core_start_testcase.sh
105
70if ENABLE_TEST_RUN 106if ENABLE_TEST_RUN
71AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 107AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
72TESTS = $(check_PROGRAMS) 108TESTS = $(check_PROGRAMS) \
109 $(check_SCRIPTS)
73endif 110endif
74 111
75test_core_api_SOURCES = \
76 test_core_api.c
77test_core_api_LDADD = \
78 libgnunetcore.la \
79 $(top_builddir)/src/ats/libgnunetats.la \
80 $(top_builddir)/src/util/libgnunetutil.la
81
82test_core_api_reliability_SOURCES = \
83 test_core_api_reliability.c
84test_core_api_reliability_LDADD = \
85 libgnunetcore.la \
86 $(top_builddir)/src/ats/libgnunetats.la \
87 $(top_builddir)/src/util/libgnunetutil.la
88
89test_core_api_send_to_self_SOURCES = \ 112test_core_api_send_to_self_SOURCES = \
90 test_core_api_send_to_self.c 113 test_core_api_send_to_self.c
91test_core_api_send_to_self_LDADD = \ 114test_core_api_send_to_self_LDADD = \
@@ -100,31 +123,8 @@ test_core_api_start_only_LDADD = \
100 libgnunetcore.la \ 123 libgnunetcore.la \
101 $(top_builddir)/src/util/libgnunetutil.la 124 $(top_builddir)/src/util/libgnunetutil.la
102 125
103test_core_quota_compliance_symmetric_SOURCES = \
104 test_core_quota_compliance.c
105test_core_quota_compliance_symmetric_LDADD = \
106 libgnunetcore.la \
107 $(top_builddir)/src/ats/libgnunetats.la \
108 $(top_builddir)/src/util/libgnunetutil.la \
109 $(top_builddir)/src/statistics/libgnunetstatistics.la
110
111test_core_quota_compliance_asymmetric_send_limited_SOURCES = \
112 test_core_quota_compliance.c
113test_core_quota_compliance_asymmetric_send_limited_LDADD = \
114 libgnunetcore.la \
115 $(top_builddir)/src/ats/libgnunetats.la \
116 $(top_builddir)/src/util/libgnunetutil.la \
117 $(top_builddir)/src/statistics/libgnunetstatistics.la
118
119test_core_quota_compliance_asymmetric_recv_limited_SOURCES = \
120 test_core_quota_compliance.c
121test_core_quota_compliance_asymmetric_recv_limited_LDADD = \
122 libgnunetcore.la \
123 $(top_builddir)/src/ats/libgnunetats.la \
124 $(top_builddir)/src/util/libgnunetutil.la \
125 $(top_builddir)/src/statistics/libgnunetstatistics.la
126
127EXTRA_DIST = \ 126EXTRA_DIST = \
127 test_core_start_testcase.sh \
128 test_core_defaults.conf \ 128 test_core_defaults.conf \
129 test_core_api_data.conf \ 129 test_core_api_data.conf \
130 test_core_api_peer1.conf \ 130 test_core_api_peer1.conf \