aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-10-18 14:31:24 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-10-18 14:31:24 +0200
commit2f93ff3b6d3524e1e6dc23f70966fbae3ca9d3af (patch)
tree8c9d286043722488bc12dd3881641d45ac782796 /src/core/Makefile.am
parent1867346fd2615492fd1392849039f7cc621299f4 (diff)
downloadgnunet-2f93ff3b6d3524e1e6dc23f70966fbae3ca9d3af.tar.gz
gnunet-2f93ff3b6d3524e1e6dc23f70966fbae3ca9d3af.zip
BUILD: Move core to service/cli
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am138
1 files changed, 0 insertions, 138 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
deleted file mode 100644
index b1d932ace..000000000
--- a/src/core/Makefile.am
+++ /dev/null
@@ -1,138 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6plugindir = $(libdir)/gnunet
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 core.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIB = -lgcov
16endif
17
18plugin_LTLIBRARIES = \
19 libgnunet_test_core_plugin_cmd_just_run.la
20
21TESTING_LIBS = \
22 libgnunetcoretesting.la
23
24lib_LTLIBRARIES = \
25 libgnunetcore.la \
26 $(TESTING_LIBS)
27
28libgnunetcore_la_SOURCES = \
29 core_api.c core.h \
30 core_api_monitor_peers.c
31libgnunetcore_la_LIBADD = \
32 $(top_builddir)/src/lib/util/libgnunetutil.la \
33 $(GN_LIBINTL) $(XLIB)
34libgnunetcore_la_LDFLAGS = \
35 $(GN_LIB_LDFLAGS) \
36 -version-info 0:1:0
37
38libgnunet_test_core_plugin_cmd_just_run_la_SOURCES = \
39 test_core_plugin_cmd_just_run.c
40libgnunet_test_core_plugin_cmd_just_run_la_LIBADD = \
41 libgnunetcoretesting.la \
42 $(top_builddir)/src/transport/libgnunettransportapplication.la \
43 $(top_builddir)/src/transport/libgnunettransportcore.la \
44 $(top_builddir)/src/lib/testing/libgnunettesting.la \
45 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
46 $(top_builddir)/src/statistics/libgnunetstatistics.la \
47 $(top_builddir)/src/lib/hello/libgnunethello.la \
48 $(top_builddir)/src/service/arm/libgnunetarm.la \
49 $(top_builddir)/src/lib/util/libgnunetutil.la \
50 $(LTLIBINTL)
51libgnunet_test_core_plugin_cmd_just_run_la_LDFLAGS = \
52 $(GN_PLUGIN_LDFLAGS)
53
54libgnunetcoretesting_la_SOURCES = \
55 core_api_cmd_connecting_peers.c
56libgnunetcoretesting_la_LIBADD = \
57 $(top_builddir)/src/lib/testing/libgnunettesting.la \
58 $(top_builddir)/src/service/arm/libgnunetarm.la \
59 $(top_builddir)/src/transport/libgnunettransportapplication.la \
60 $(top_builddir)/src/transport/libgnunettransportcore.la \
61 $(top_builddir)/src/lib/util/libgnunetutil.la
62libgnunetcoretesting_la_LDFLAGS = \
63 $(GN_LIBINTL) \
64 $(GN_LIB_LDFLAGS) \
65 -version-info 0:0:0
66
67
68libexec_PROGRAMS = \
69 gnunet-service-core
70
71bin_PROGRAMS = \
72 gnunet-core
73
74gnunet_service_core_SOURCES = \
75 gnunet-service-core.c gnunet-service-core.h \
76 gnunet-service-core_kx.c gnunet-service-core_kx.h \
77 gnunet-service-core_sessions.c gnunet-service-core_sessions.h \
78 gnunet-service-core_typemap.c gnunet-service-core_typemap.h
79gnunet_service_core_LDADD = \
80 $(top_builddir)/src/statistics/libgnunetstatistics.la \
81 $(top_builddir)/src/transport/libgnunettransportapplication.la \
82 $(top_builddir)/src/transport/libgnunettransportcore.la \
83 $(top_builddir)/src/lib/util/libgnunetutil.la \
84 $(GN_LIBINTL) $(Z_LIBS)
85
86
87gnunet_core_SOURCES = \
88 gnunet-core.c
89gnunet_core_LDADD = \
90 libgnunetcore.la \
91 $(top_builddir)/src/lib/util/libgnunetutil.la
92gnunet_core_LDFLAGS = \
93 $(GN_LIBINTL)
94
95TESTING_TESTS = \
96 test_core_api_send_to_self
97
98check_PROGRAMS = \
99 test_core_api_start_only \
100 $(TESTING_TESTS)
101
102# Only test TNG if we run experimental
103check_SCRIPTS= \
104 test_core_start_testcase.sh
105
106if ENABLE_TEST_RUN
107AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
108TESTS = $(check_PROGRAMS) \
109 $(check_SCRIPTS)
110endif
111
112test_core_api_send_to_self_SOURCES = \
113 test_core_api_send_to_self.c
114test_core_api_send_to_self_LDADD = \
115 libgnunetcore.la \
116 $(top_builddir)/src/lib/testing/libgnunettesting.la \
117 $(top_builddir)/src/lib/util/libgnunetutil.la
118
119test_core_api_start_only_SOURCES = \
120 test_core_api_start_only.c
121test_core_api_start_only_LDADD = \
122 $(top_builddir)/src/lib/testing/libgnunettesting.la \
123 libgnunetcore.la \
124 $(top_builddir)/src/lib/util/libgnunetutil.la
125
126EXTRA_DIST = \
127 test_core_start_testcase.sh \
128 test_core_defaults.conf \
129 test_core_api_data.conf \
130 test_core_api_peer1.conf \
131 test_core_api_peer2.conf \
132 test_core_api_send_to_self.conf \
133 test_core_quota_asymmetric_recv_limited_peer1.conf \
134 test_core_quota_asymmetric_recv_limited_peer2.conf \
135 test_core_quota_asymmetric_send_limit_peer1.conf \
136 test_core_quota_asymmetric_send_limit_peer2.conf \
137 test_core_quota_peer1.conf \
138 test_core_quota_peer2.conf