aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-10-18 13:37:38 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-10-18 13:37:38 +0200
commit9ef4abad615bea12d13be542b8ae5fbeb2dfee32 (patch)
tree8875a687e004d331c9ea6a1d511a328c72b88113 /src/core/Makefile.am
parente95236b3ed78cd597c15f34b89385295702b627f (diff)
downloadgnunet-9ef4abad615bea12d13be542b8ae5fbeb2dfee32.tar.gz
gnunet-9ef4abad615bea12d13be542b8ae5fbeb2dfee32.zip
NEWS: Refactoring components under src/ into lib/, plugin/, cli/ and service/
This also includes a necessary API refactoring of crypto from IDENTITY to UTIL.
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index 5e2a74ec3..7a9046c57 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -29,7 +29,7 @@ libgnunetcore_la_SOURCES = \
29 core_api.c core.h \ 29 core_api.c core.h \
30 core_api_monitor_peers.c 30 core_api_monitor_peers.c
31libgnunetcore_la_LIBADD = \ 31libgnunetcore_la_LIBADD = \
32 $(top_builddir)/src/util/libgnunetutil.la \ 32 $(top_builddir)/src/lib/util/libgnunetutil.la \
33 $(GN_LIBINTL) $(XLIB) 33 $(GN_LIBINTL) $(XLIB)
34libgnunetcore_la_LDFLAGS = \ 34libgnunetcore_la_LDFLAGS = \
35 $(GN_LIB_LDFLAGS) \ 35 $(GN_LIB_LDFLAGS) \
@@ -44,9 +44,9 @@ libgnunet_test_core_plugin_cmd_just_run_la_LIBADD = \
44 $(top_builddir)/src/testing/libgnunettesting.la \ 44 $(top_builddir)/src/testing/libgnunettesting.la \
45 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 45 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
46 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 46 $(top_builddir)/src/statistics/libgnunetstatistics.la \
47 $(top_builddir)/src/hello/libgnunethello.la \ 47 $(top_builddir)/src/lib/hello/libgnunethello.la \
48 $(top_builddir)/src/arm/libgnunetarm.la \ 48 $(top_builddir)/src/arm/libgnunetarm.la \
49 $(top_builddir)/src/util/libgnunetutil.la \ 49 $(top_builddir)/src/lib/util/libgnunetutil.la \
50 $(LTLIBINTL) 50 $(LTLIBINTL)
51libgnunet_test_core_plugin_cmd_just_run_la_LDFLAGS = \ 51libgnunet_test_core_plugin_cmd_just_run_la_LDFLAGS = \
52 $(GN_PLUGIN_LDFLAGS) 52 $(GN_PLUGIN_LDFLAGS)
@@ -58,7 +58,7 @@ libgnunetcoretesting_la_LIBADD = \
58 $(top_builddir)/src/arm/libgnunetarm.la \ 58 $(top_builddir)/src/arm/libgnunetarm.la \
59 $(top_builddir)/src/transport/libgnunettransportapplication.la \ 59 $(top_builddir)/src/transport/libgnunettransportapplication.la \
60 $(top_builddir)/src/transport/libgnunettransportcore.la \ 60 $(top_builddir)/src/transport/libgnunettransportcore.la \
61 $(top_builddir)/src/util/libgnunetutil.la 61 $(top_builddir)/src/lib/util/libgnunetutil.la
62libgnunetcoretesting_la_LDFLAGS = \ 62libgnunetcoretesting_la_LDFLAGS = \
63 $(GN_LIBINTL) \ 63 $(GN_LIBINTL) \
64 $(GN_LIB_LDFLAGS) \ 64 $(GN_LIB_LDFLAGS) \
@@ -80,7 +80,7 @@ gnunet_service_core_LDADD = \
80 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 80 $(top_builddir)/src/statistics/libgnunetstatistics.la \
81 $(top_builddir)/src/transport/libgnunettransportapplication.la \ 81 $(top_builddir)/src/transport/libgnunettransportapplication.la \
82 $(top_builddir)/src/transport/libgnunettransportcore.la \ 82 $(top_builddir)/src/transport/libgnunettransportcore.la \
83 $(top_builddir)/src/util/libgnunetutil.la \ 83 $(top_builddir)/src/lib/util/libgnunetutil.la \
84 $(GN_LIBINTL) $(Z_LIBS) 84 $(GN_LIBINTL) $(Z_LIBS)
85 85
86 86
@@ -88,7 +88,7 @@ gnunet_core_SOURCES = \
88 gnunet-core.c 88 gnunet-core.c
89gnunet_core_LDADD = \ 89gnunet_core_LDADD = \
90 libgnunetcore.la \ 90 libgnunetcore.la \
91 $(top_builddir)/src/util/libgnunetutil.la 91 $(top_builddir)/src/lib/util/libgnunetutil.la
92gnunet_core_LDFLAGS = \ 92gnunet_core_LDFLAGS = \
93 $(GN_LIBINTL) 93 $(GN_LIBINTL)
94 94
@@ -114,14 +114,14 @@ test_core_api_send_to_self_SOURCES = \
114test_core_api_send_to_self_LDADD = \ 114test_core_api_send_to_self_LDADD = \
115 libgnunetcore.la \ 115 libgnunetcore.la \
116 $(top_builddir)/src/testing/libgnunettesting.la \ 116 $(top_builddir)/src/testing/libgnunettesting.la \
117 $(top_builddir)/src/util/libgnunetutil.la 117 $(top_builddir)/src/lib/util/libgnunetutil.la
118 118
119test_core_api_start_only_SOURCES = \ 119test_core_api_start_only_SOURCES = \
120 test_core_api_start_only.c 120 test_core_api_start_only.c
121test_core_api_start_only_LDADD = \ 121test_core_api_start_only_LDADD = \
122 $(top_builddir)/src/testing/libgnunettesting.la \ 122 $(top_builddir)/src/testing/libgnunettesting.la \
123 libgnunetcore.la \ 123 libgnunetcore.la \
124 $(top_builddir)/src/util/libgnunetutil.la 124 $(top_builddir)/src/lib/util/libgnunetutil.la
125 125
126EXTRA_DIST = \ 126EXTRA_DIST = \
127 test_core_start_testcase.sh \ 127 test_core_start_testcase.sh \