aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2010-07-28 20:19:39 +0000
committerChristian Grothoff <christian@grothoff.org>2010-07-28 20:19:39 +0000
commit7d719b15594de606dd65d9a93e74a605bb0637f3 (patch)
treecb3cb3d72c3add3dc6068c767159faf15e69c3a1 /src/datastore/Makefile.am
parentd72151f265cb7aacb184c1fbd160d6a323ccd9aa (diff)
downloadgnunet-7d719b15594de606dd65d9a93e74a605bb0637f3.tar.gz
gnunet-7d719b15594de606dd65d9a93e74a605bb0637f3.zip
fixing #1589
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 7904907b6..6fdf73d1a 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -35,9 +35,12 @@ gnunet_service_datastore_LDADD = \
35 $(top_builddir)/src/util/libgnunetutil.la \ 35 $(top_builddir)/src/util/libgnunetutil.la \
36 $(GN_LIBINTL) 36 $(GN_LIBINTL)
37 37
38if HAVE_SQLITE
39 SQLITE_PLUGIN = libgnunet_plugin_datastore_sqlite.la
40endif
38 41
39plugin_LTLIBRARIES = \ 42plugin_LTLIBRARIES = \
40 libgnunet_plugin_datastore_sqlite.la \ 43 $(SQLITE_PLUGIN) \
41 libgnunet_plugin_datastore_template.la 44 libgnunet_plugin_datastore_template.la
42 45
43 46
@@ -57,12 +60,18 @@ libgnunet_plugin_datastore_template_la_LDFLAGS = \
57 $(GN_PLUGIN_LDFLAGS) 60 $(GN_PLUGIN_LDFLAGS)
58 61
59 62
60check_PROGRAMS = \ 63if HAVE_SQLITE
64SQLITE_TESTS = \
61 test_datastore_api \ 65 test_datastore_api \
62 test_datastore_api_management \ 66 test_datastore_api_management \
63 perf_datastore_api \ 67 perf_datastore_api \
64 perf_plugin_datastore 68 perf_plugin_datastore
65 69
70endif
71
72check_PROGRAMS = \
73 $(SQLITE_TESTS)
74
66if !DISABLE_TEST_RUN 75if !DISABLE_TEST_RUN
67TESTS = $(check_PROGRAMS) 76TESTS = $(check_PROGRAMS)
68endif 77endif