aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-06-10 11:43:20 +0000
committerChristian Grothoff <christian@grothoff.org>2012-06-10 11:43:20 +0000
commitdadbf4c950bf4cd459c95ac4ab61a02af7b3668b (patch)
treeddaf0644dcd97fbef7f67a68eff2a5cf204b0bb7 /src/datastore/Makefile.am
parent8efaae301b29ec7cbdb921ac5e6b30ae2c143568 (diff)
downloadgnunet-dadbf4c950bf4cd459c95ac4ab61a02af7b3668b.tar.gz
gnunet-dadbf4c950bf4cd459c95ac4ab61a02af7b3668b.zip
-using new testing api to determine plugin name
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index cd5b0d481..4000e9981 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -162,11 +162,13 @@ perf_datastore_api_sqlite_LDADD = \
162perf_plugin_datastore_sqlite_SOURCES = \ 162perf_plugin_datastore_sqlite_SOURCES = \
163 perf_plugin_datastore.c 163 perf_plugin_datastore.c
164perf_plugin_datastore_sqlite_LDADD = \ 164perf_plugin_datastore_sqlite_LDADD = \
165 $(top_builddir)/src/testing/libgnunettesting.la \
165 $(top_builddir)/src/util/libgnunetutil.la 166 $(top_builddir)/src/util/libgnunetutil.la
166 167
167test_plugin_datastore_sqlite_SOURCES = \ 168test_plugin_datastore_sqlite_SOURCES = \
168 test_plugin_datastore.c 169 test_plugin_datastore.c
169test_plugin_datastore_sqlite_LDADD = \ 170test_plugin_datastore_sqlite_LDADD = \
171 $(top_builddir)/src/testing/libgnunettesting.la \
170 $(top_builddir)/src/util/libgnunetutil.la 172 $(top_builddir)/src/util/libgnunetutil.la
171 173
172 174
@@ -194,11 +196,13 @@ perf_datastore_api_mysql_LDADD = \
194test_plugin_datastore_mysql_SOURCES = \ 196test_plugin_datastore_mysql_SOURCES = \
195 test_plugin_datastore.c 197 test_plugin_datastore.c
196test_plugin_datastore_mysql_LDADD = \ 198test_plugin_datastore_mysql_LDADD = \
199 $(top_builddir)/src/testing/libgnunettesting.la \
197 $(top_builddir)/src/util/libgnunetutil.la 200 $(top_builddir)/src/util/libgnunetutil.la
198 201
199perf_plugin_datastore_mysql_SOURCES = \ 202perf_plugin_datastore_mysql_SOURCES = \
200 perf_plugin_datastore.c 203 perf_plugin_datastore.c
201perf_plugin_datastore_mysql_LDADD = \ 204perf_plugin_datastore_mysql_LDADD = \
205 $(top_builddir)/src/testing/libgnunettesting.la \
202 $(top_builddir)/src/util/libgnunetutil.la 206 $(top_builddir)/src/util/libgnunetutil.la
203 207
204 208
@@ -226,11 +230,13 @@ perf_datastore_api_postgres_LDADD = \
226test_plugin_datastore_postgres_SOURCES = \ 230test_plugin_datastore_postgres_SOURCES = \
227 test_plugin_datastore.c 231 test_plugin_datastore.c
228test_plugin_datastore_postgres_LDADD = \ 232test_plugin_datastore_postgres_LDADD = \
233 $(top_builddir)/src/testing/libgnunettesting.la \
229 $(top_builddir)/src/util/libgnunetutil.la 234 $(top_builddir)/src/util/libgnunetutil.la
230 235
231perf_plugin_datastore_postgres_SOURCES = \ 236perf_plugin_datastore_postgres_SOURCES = \
232 perf_plugin_datastore.c 237 perf_plugin_datastore.c
233perf_plugin_datastore_postgres_LDADD = \ 238perf_plugin_datastore_postgres_LDADD = \
239 $(top_builddir)/src/testing/libgnunettesting.la \
234 $(top_builddir)/src/util/libgnunetutil.la 240 $(top_builddir)/src/util/libgnunetutil.la
235 241
236 242