aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-04-03 20:00:42 +0000
committerChristian Grothoff <christian@grothoff.org>2011-04-03 20:00:42 +0000
commite8f35bb025c25839a52fb502e452393831e4e6f0 (patch)
tree7a056253bddc61b1e6a3258567e176af128c2b67 /src/datastore/Makefile.am
parent9f871785d57da57ba128ac2279fda1db1d9b8bfb (diff)
downloadgnunet-e8f35bb025c25839a52fb502e452393831e4e6f0.tar.gz
gnunet-e8f35bb025c25839a52fb502e452393831e4e6f0.zip
improving datastore API --- not working yet
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 4cd80d090..ec0598819 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -37,6 +37,7 @@ gnunet_service_datastore_LDADD = \
37 $(GN_LIBINTL) 37 $(GN_LIBINTL)
38 38
39if HAVE_MYSQL 39if HAVE_MYSQL
40if HAVE_EXPERIMENTAL
40 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la 41 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la
41 MYSQL_TESTS = \ 42 MYSQL_TESTS = \
42 test_datastore_api_mysql \ 43 test_datastore_api_mysql \
@@ -44,6 +45,7 @@ if HAVE_MYSQL
44 perf_datastore_api_mysql \ 45 perf_datastore_api_mysql \
45 perf_plugin_datastore_mysql 46 perf_plugin_datastore_mysql
46endif 47endif
48endif
47if HAVE_SQLITE 49if HAVE_SQLITE
48 SQLITE_PLUGIN = libgnunet_plugin_datastore_sqlite.la 50 SQLITE_PLUGIN = libgnunet_plugin_datastore_sqlite.la
49 SQLITE_TESTS = \ 51 SQLITE_TESTS = \
@@ -53,6 +55,7 @@ if HAVE_SQLITE
53 perf_plugin_datastore_sqlite 55 perf_plugin_datastore_sqlite
54endif 56endif
55if HAVE_POSTGRES 57if HAVE_POSTGRES
58if HAVE_EXPERIMENTAL
56 POSTGRES_PLUGIN = libgnunet_plugin_datastore_postgres.la 59 POSTGRES_PLUGIN = libgnunet_plugin_datastore_postgres.la
57 POSTGRES_TESTS = \ 60 POSTGRES_TESTS = \
58 test_datastore_api_postgres \ 61 test_datastore_api_postgres \
@@ -60,6 +63,7 @@ if HAVE_POSTGRES
60 perf_datastore_api_postgres \ 63 perf_datastore_api_postgres \
61 perf_plugin_datastore_postgres 64 perf_plugin_datastore_postgres
62endif 65endif
66endif
63 67
64plugin_LTLIBRARIES = \ 68plugin_LTLIBRARIES = \
65 $(SQLITE_PLUGIN) \ 69 $(SQLITE_PLUGIN) \