aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-06-02 08:54:18 +0000
committerChristian Grothoff <christian@grothoff.org>2015-06-02 08:54:18 +0000
commitedb4ddf051d91a2169d46f07b1bfea6df4d216bb (patch)
treee3b1a1095ece34ca21a420a290ad740663ec36a5 /src/datastore/Makefile.am
parenta2417d5b3fc632fb1bacca6594c50a0ef7ffd23a (diff)
downloadgnunet-edb4ddf051d91a2169d46f07b1bfea6df4d216bb.tar.gz
gnunet-edb4ddf051d91a2169d46f07b1bfea6df4d216bb.zip
-noinst-ing non-functional binaries/libraries that just exist as examples/templates
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am56
1 files changed, 30 insertions, 26 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 241fa5263..4ad0ae028 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -24,11 +24,11 @@ lib_LTLIBRARIES = \
24 libgnunetdatastore.la 24 libgnunetdatastore.la
25 25
26libgnunetdatastore_la_SOURCES = \ 26libgnunetdatastore_la_SOURCES = \
27 datastore_api.c datastore.h 27 datastore_api.c datastore.h
28libgnunetdatastore_la_LIBADD = \ 28libgnunetdatastore_la_LIBADD = \
29 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 29 $(top_builddir)/src/statistics/libgnunetstatistics.la \
30 $(top_builddir)/src/util/libgnunetutil.la \ 30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(GN_LIBINTL) 31 $(GN_LIBINTL)
32libgnunetdatastore_la_LDFLAGS = \ 32libgnunetdatastore_la_LDFLAGS = \
33 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 33 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
34 -version-info 1:0:0 34 -version-info 1:0:0
@@ -40,14 +40,14 @@ libexec_PROGRAMS = \
40 gnunet-service-datastore 40 gnunet-service-datastore
41 41
42gnunet_service_datastore_SOURCES = \ 42gnunet_service_datastore_SOURCES = \
43 gnunet-service-datastore.c 43 gnunet-service-datastore.c
44gnunet_service_datastore_LDADD = \ 44gnunet_service_datastore_LDADD = \
45 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 45 $(top_builddir)/src/statistics/libgnunetstatistics.la \
46 $(top_builddir)/src/util/libgnunetutil.la \ 46 $(top_builddir)/src/util/libgnunetutil.la \
47 $(GN_LIBINTL) 47 $(GN_LIBINTL)
48 48
49gnunet_datastore_SOURCES = \ 49gnunet_datastore_SOURCES = \
50 gnunet-datastore.c 50 gnunet-datastore.c
51gnunet_datastore_LDADD = \ 51gnunet_datastore_LDADD = \
52 libgnunetdatastore.la \ 52 libgnunetdatastore.la \
53 $(top_builddir)/src/util/libgnunetutil.la \ 53 $(top_builddir)/src/util/libgnunetutil.la \
@@ -104,8 +104,12 @@ plugin_LTLIBRARIES = \
104 $(SQLITE_PLUGIN) \ 104 $(SQLITE_PLUGIN) \
105 $(MYSQL_PLUGIN) \ 105 $(MYSQL_PLUGIN) \
106 $(POSTGRES_PLUGIN) \ 106 $(POSTGRES_PLUGIN) \
107 libgnunet_plugin_datastore_heap.la \ 107 libgnunet_plugin_datastore_heap.la
108 libgnunet_plugin_datastore_template.la 108
109# Real plugins should of course go into
110# plugin_LTLIBRARIES
111noinst_LTLIBRARIES = \
112 libgnunet_plugin_datastore_template.la
109 113
110 114
111libgnunet_plugin_datastore_sqlite_la_SOURCES = \ 115libgnunet_plugin_datastore_sqlite_la_SOURCES = \
@@ -178,33 +182,33 @@ test_datastore_api_heap_SOURCES = \
178test_datastore_api_heap_LDADD = \ 182test_datastore_api_heap_LDADD = \
179 $(top_builddir)/src/testing/libgnunettesting.la \ 183 $(top_builddir)/src/testing/libgnunettesting.la \
180 libgnunetdatastore.la \ 184 libgnunetdatastore.la \
181 $(top_builddir)/src/util/libgnunetutil.la 185 $(top_builddir)/src/util/libgnunetutil.la
182 186
183test_datastore_api_management_heap_SOURCES = \ 187test_datastore_api_management_heap_SOURCES = \
184 test_datastore_api_management.c 188 test_datastore_api_management.c
185test_datastore_api_management_heap_LDADD = \ 189test_datastore_api_management_heap_LDADD = \
186 $(top_builddir)/src/testing/libgnunettesting.la \ 190 $(top_builddir)/src/testing/libgnunettesting.la \
187 libgnunetdatastore.la \ 191 libgnunetdatastore.la \
188 $(top_builddir)/src/util/libgnunetutil.la 192 $(top_builddir)/src/util/libgnunetutil.la
189 193
190perf_datastore_api_heap_SOURCES = \ 194perf_datastore_api_heap_SOURCES = \
191 perf_datastore_api.c 195 perf_datastore_api.c
192perf_datastore_api_heap_LDADD = \ 196perf_datastore_api_heap_LDADD = \
193 $(top_builddir)/src/testing/libgnunettesting.la \ 197 $(top_builddir)/src/testing/libgnunettesting.la \
194 libgnunetdatastore.la \ 198 libgnunetdatastore.la \
195 $(top_builddir)/src/util/libgnunetutil.la 199 $(top_builddir)/src/util/libgnunetutil.la
196 200
197perf_plugin_datastore_heap_SOURCES = \ 201perf_plugin_datastore_heap_SOURCES = \
198 perf_plugin_datastore.c 202 perf_plugin_datastore.c
199perf_plugin_datastore_heap_LDADD = \ 203perf_plugin_datastore_heap_LDADD = \
200 $(top_builddir)/src/testing/libgnunettesting.la \ 204 $(top_builddir)/src/testing/libgnunettesting.la \
201 $(top_builddir)/src/util/libgnunetutil.la 205 $(top_builddir)/src/util/libgnunetutil.la
202 206
203test_plugin_datastore_heap_SOURCES = \ 207test_plugin_datastore_heap_SOURCES = \
204 test_plugin_datastore.c 208 test_plugin_datastore.c
205test_plugin_datastore_heap_LDADD = \ 209test_plugin_datastore_heap_LDADD = \
206 $(top_builddir)/src/testing/libgnunettesting.la \ 210 $(top_builddir)/src/testing/libgnunettesting.la \
207 $(top_builddir)/src/util/libgnunetutil.la 211 $(top_builddir)/src/util/libgnunetutil.la
208 212
209 213
210test_datastore_api_sqlite_SOURCES = \ 214test_datastore_api_sqlite_SOURCES = \
@@ -212,33 +216,33 @@ test_datastore_api_sqlite_SOURCES = \
212test_datastore_api_sqlite_LDADD = \ 216test_datastore_api_sqlite_LDADD = \
213 $(top_builddir)/src/testing/libgnunettesting.la \ 217 $(top_builddir)/src/testing/libgnunettesting.la \
214 libgnunetdatastore.la \ 218 libgnunetdatastore.la \
215 $(top_builddir)/src/util/libgnunetutil.la 219 $(top_builddir)/src/util/libgnunetutil.la
216 220
217test_datastore_api_management_sqlite_SOURCES = \ 221test_datastore_api_management_sqlite_SOURCES = \
218 test_datastore_api_management.c 222 test_datastore_api_management.c
219test_datastore_api_management_sqlite_LDADD = \ 223test_datastore_api_management_sqlite_LDADD = \
220 $(top_builddir)/src/testing/libgnunettesting.la \ 224 $(top_builddir)/src/testing/libgnunettesting.la \
221 libgnunetdatastore.la \ 225 libgnunetdatastore.la \
222 $(top_builddir)/src/util/libgnunetutil.la 226 $(top_builddir)/src/util/libgnunetutil.la
223 227
224perf_datastore_api_sqlite_SOURCES = \ 228perf_datastore_api_sqlite_SOURCES = \
225 perf_datastore_api.c 229 perf_datastore_api.c
226perf_datastore_api_sqlite_LDADD = \ 230perf_datastore_api_sqlite_LDADD = \
227 $(top_builddir)/src/testing/libgnunettesting.la \ 231 $(top_builddir)/src/testing/libgnunettesting.la \
228 libgnunetdatastore.la \ 232 libgnunetdatastore.la \
229 $(top_builddir)/src/util/libgnunetutil.la 233 $(top_builddir)/src/util/libgnunetutil.la
230 234
231perf_plugin_datastore_sqlite_SOURCES = \ 235perf_plugin_datastore_sqlite_SOURCES = \
232 perf_plugin_datastore.c 236 perf_plugin_datastore.c
233perf_plugin_datastore_sqlite_LDADD = \ 237perf_plugin_datastore_sqlite_LDADD = \
234 $(top_builddir)/src/testing/libgnunettesting.la \ 238 $(top_builddir)/src/testing/libgnunettesting.la \
235 $(top_builddir)/src/util/libgnunetutil.la 239 $(top_builddir)/src/util/libgnunetutil.la
236 240
237test_plugin_datastore_sqlite_SOURCES = \ 241test_plugin_datastore_sqlite_SOURCES = \
238 test_plugin_datastore.c 242 test_plugin_datastore.c
239test_plugin_datastore_sqlite_LDADD = \ 243test_plugin_datastore_sqlite_LDADD = \
240 $(top_builddir)/src/testing/libgnunettesting.la \ 244 $(top_builddir)/src/testing/libgnunettesting.la \
241 $(top_builddir)/src/util/libgnunetutil.la 245 $(top_builddir)/src/util/libgnunetutil.la
242 246
243 247
244test_datastore_api_mysql_SOURCES = \ 248test_datastore_api_mysql_SOURCES = \
@@ -246,33 +250,33 @@ test_datastore_api_mysql_SOURCES = \
246test_datastore_api_mysql_LDADD = \ 250test_datastore_api_mysql_LDADD = \
247 $(top_builddir)/src/testing/libgnunettesting.la \ 251 $(top_builddir)/src/testing/libgnunettesting.la \
248 libgnunetdatastore.la \ 252 libgnunetdatastore.la \
249 $(top_builddir)/src/util/libgnunetutil.la 253 $(top_builddir)/src/util/libgnunetutil.la
250 254
251test_datastore_api_management_mysql_SOURCES = \ 255test_datastore_api_management_mysql_SOURCES = \
252 test_datastore_api_management.c 256 test_datastore_api_management.c
253test_datastore_api_management_mysql_LDADD = \ 257test_datastore_api_management_mysql_LDADD = \
254 $(top_builddir)/src/testing/libgnunettesting.la \ 258 $(top_builddir)/src/testing/libgnunettesting.la \
255 libgnunetdatastore.la \ 259 libgnunetdatastore.la \
256 $(top_builddir)/src/util/libgnunetutil.la 260 $(top_builddir)/src/util/libgnunetutil.la
257 261
258perf_datastore_api_mysql_SOURCES = \ 262perf_datastore_api_mysql_SOURCES = \
259 perf_datastore_api.c 263 perf_datastore_api.c
260perf_datastore_api_mysql_LDADD = \ 264perf_datastore_api_mysql_LDADD = \
261 $(top_builddir)/src/testing/libgnunettesting.la \ 265 $(top_builddir)/src/testing/libgnunettesting.la \
262 libgnunetdatastore.la \ 266 libgnunetdatastore.la \
263 $(top_builddir)/src/util/libgnunetutil.la 267 $(top_builddir)/src/util/libgnunetutil.la
264 268
265test_plugin_datastore_mysql_SOURCES = \ 269test_plugin_datastore_mysql_SOURCES = \
266 test_plugin_datastore.c 270 test_plugin_datastore.c
267test_plugin_datastore_mysql_LDADD = \ 271test_plugin_datastore_mysql_LDADD = \
268 $(top_builddir)/src/testing/libgnunettesting.la \ 272 $(top_builddir)/src/testing/libgnunettesting.la \
269 $(top_builddir)/src/util/libgnunetutil.la 273 $(top_builddir)/src/util/libgnunetutil.la
270 274
271perf_plugin_datastore_mysql_SOURCES = \ 275perf_plugin_datastore_mysql_SOURCES = \
272 perf_plugin_datastore.c 276 perf_plugin_datastore.c
273perf_plugin_datastore_mysql_LDADD = \ 277perf_plugin_datastore_mysql_LDADD = \
274 $(top_builddir)/src/testing/libgnunettesting.la \ 278 $(top_builddir)/src/testing/libgnunettesting.la \
275 $(top_builddir)/src/util/libgnunetutil.la 279 $(top_builddir)/src/util/libgnunetutil.la
276 280
277 281
278test_datastore_api_postgres_SOURCES = \ 282test_datastore_api_postgres_SOURCES = \
@@ -280,33 +284,33 @@ test_datastore_api_postgres_SOURCES = \
280test_datastore_api_postgres_LDADD = \ 284test_datastore_api_postgres_LDADD = \
281 $(top_builddir)/src/testing/libgnunettesting.la \ 285 $(top_builddir)/src/testing/libgnunettesting.la \
282 libgnunetdatastore.la \ 286 libgnunetdatastore.la \
283 $(top_builddir)/src/util/libgnunetutil.la 287 $(top_builddir)/src/util/libgnunetutil.la
284 288
285test_datastore_api_management_postgres_SOURCES = \ 289test_datastore_api_management_postgres_SOURCES = \
286 test_datastore_api_management.c 290 test_datastore_api_management.c
287test_datastore_api_management_postgres_LDADD = \ 291test_datastore_api_management_postgres_LDADD = \
288 $(top_builddir)/src/testing/libgnunettesting.la \ 292 $(top_builddir)/src/testing/libgnunettesting.la \
289 libgnunetdatastore.la \ 293 libgnunetdatastore.la \
290 $(top_builddir)/src/util/libgnunetutil.la 294 $(top_builddir)/src/util/libgnunetutil.la
291 295
292perf_datastore_api_postgres_SOURCES = \ 296perf_datastore_api_postgres_SOURCES = \
293 perf_datastore_api.c 297 perf_datastore_api.c
294perf_datastore_api_postgres_LDADD = \ 298perf_datastore_api_postgres_LDADD = \
295 $(top_builddir)/src/testing/libgnunettesting.la \ 299 $(top_builddir)/src/testing/libgnunettesting.la \
296 libgnunetdatastore.la \ 300 libgnunetdatastore.la \
297 $(top_builddir)/src/util/libgnunetutil.la 301 $(top_builddir)/src/util/libgnunetutil.la
298 302
299test_plugin_datastore_postgres_SOURCES = \ 303test_plugin_datastore_postgres_SOURCES = \
300 test_plugin_datastore.c 304 test_plugin_datastore.c
301test_plugin_datastore_postgres_LDADD = \ 305test_plugin_datastore_postgres_LDADD = \
302 $(top_builddir)/src/testing/libgnunettesting.la \ 306 $(top_builddir)/src/testing/libgnunettesting.la \
303 $(top_builddir)/src/util/libgnunetutil.la 307 $(top_builddir)/src/util/libgnunetutil.la
304 308
305perf_plugin_datastore_postgres_SOURCES = \ 309perf_plugin_datastore_postgres_SOURCES = \
306 perf_plugin_datastore.c 310 perf_plugin_datastore.c
307perf_plugin_datastore_postgres_LDADD = \ 311perf_plugin_datastore_postgres_LDADD = \
308 $(top_builddir)/src/testing/libgnunettesting.la \ 312 $(top_builddir)/src/testing/libgnunettesting.la \
309 $(top_builddir)/src/util/libgnunetutil.la 313 $(top_builddir)/src/util/libgnunetutil.la
310 314
311 315
312EXTRA_DIST = \ 316EXTRA_DIST = \