aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-10-06 08:40:57 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-10-06 08:40:57 +0200
commit68a06a9a5eb91ebc5ace517d8ff4bac8de96260f (patch)
tree4fc10f9a4c6cf32276fb38baaafad3dd1acfdf8d /src/dht/Makefile.am
parentd177039ea0ab26d10a1bf5dd9b191eba6139cb0e (diff)
downloadgnunet-68a06a9a5eb91ebc5ace517d8ff4bac8de96260f.tar.gz
gnunet-68a06a9a5eb91ebc5ace517d8ff4bac8de96260f.zip
BUILD: Fix dist
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am19
1 files changed, 0 insertions, 19 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index c0ff34449..d700ab8b6 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -129,27 +129,8 @@ gnunet_dht_monitor_LDFLAGS = \
129# $(top_builddir)/src/testbed/libgnunettestbed.la \ 129# $(top_builddir)/src/testbed/libgnunettestbed.la \
130# libgnunetdht.la 130# libgnunetdht.la
131 131
132check_PROGRAMS = \
133 test_dht_api \
134 test_dht_twopeer \
135 test_dht_multipeer \
136 test_dht_line \
137 test_dht_2dtorus \
138 test_dht_monitor
139
140if HAVE_EXPERIMENTAL
141# These tests still do not work as testbed does
142# not support the respective topology op
143 NEW_TESTS = test_dht_2dtorus test_dht_multipeer
144endif
145
146if ENABLE_TEST_RUN 132if ENABLE_TEST_RUN
147AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 133AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
148TESTS = test_dht_api $(check_SCRIPTS) \
149 test_dht_twopeer \
150 test_dht_line \
151 test_dht_monitor \
152 $(NEW_TESTS)
153endif 134endif
154 135
155test_dht_api_SOURCES = \ 136test_dht_api_SOURCES = \