aboutsummaryrefslogtreecommitdiff
path: root/src/dns/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-10-23 21:51:46 +0000
committerng0 <ng0@n0.is>2019-10-23 21:51:46 +0000
commit4993eac25ce2737fc45aec08f21226f523405804 (patch)
treea32a054c36102aa712a17b9b27be14b72fa8557b /src/dns/Makefile.am
parent0c13e270c31ef2896d56eb3d53ac7a5714ea1e58 (diff)
downloadgnunet-4993eac25ce2737fc45aec08f21226f523405804.tar.gz
gnunet-4993eac25ce2737fc45aec08f21226f523405804.zip
remove never working setuid helper code from the build-system.
refer to the Changelog for a longer reason. In conclusion, this is what people expect, this is what Package Managers patch away for portability, and we can't use install(1) for this because it's not a portable tool.
Diffstat (limited to 'src/dns/Makefile.am')
-rw-r--r--src/dns/Makefile.am17
1 files changed, 0 insertions, 17 deletions
diff --git a/src/dns/Makefile.am b/src/dns/Makefile.am
index 1aea7f09a..d2598bd8a 100644
--- a/src/dns/Makefile.am
+++ b/src/dns/Makefile.am
@@ -14,25 +14,8 @@ plugindir = $(libdir)/gnunet
14pkgcfg_DATA = \ 14pkgcfg_DATA = \
15 dns.conf 15 dns.conf
16 16
17if HAVE_SUDO
18SUDO_OR_DOAS_BINARY= $(SUDO_BINARY)
19else
20if HAVE_DOAS_BINARY
21SUDO_OR_DOAS_BINARY= $(DOAS_BINARY)
22endif
23endif
24
25if LINUX 17if LINUX
26HIJACKBIN = gnunet-helper-dns 18HIJACKBIN = gnunet-helper-dns
27install-exec-hook:
28 chown root $(DESTDIR)$(libexecdir)/gnunet-helper-dns
29 chgrp $(GNUNETDNS_GROUP) $(DESTDIR)$(libexecdir)/gnunet-helper-dns
30 chmod 4750 $(DESTDIR)$(libexecdir)/gnunet-helper-dns
31 chgrp $(GNUNETDNS_GROUP) $(DESTDIR)$(libexecdir)/gnunet-helper-dns
32 chown gnunet:$(GNUNETDNS_GROUP) $(DESTDIR)$(libexecdir)/gnunet-helper-dns
33 chmod 2750 $(DESTDIR)$(libexecdir)/gnunet-helper-dns
34else
35install-exec-hook:
36endif 19endif
37 20
38lib_LTLIBRARIES = \ 21lib_LTLIBRARIES = \