aboutsummaryrefslogtreecommitdiff
path: root/src/dv/Makefile.am
diff options
context:
space:
mode:
authorNathan S. Evans <evans@in.tum.de>2010-03-11 10:38:11 +0000
committerNathan S. Evans <evans@in.tum.de>2010-03-11 10:38:11 +0000
commit49da466bce647497cfc034db9e9761804e9d1a36 (patch)
tree65e289dcdb8c985ffa9ff4d243af6daeb83a6477 /src/dv/Makefile.am
parente927f9bbf828bfc5038323c39aa3046ef948afe5 (diff)
downloadgnunet-49da466bce647497cfc034db9e9761804e9d1a36.tar.gz
gnunet-49da466bce647497cfc034db9e9761804e9d1a36.zip
shell for dv plugin and service, not yet working
Diffstat (limited to 'src/dv/Makefile.am')
-rw-r--r--src/dv/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/src/dv/Makefile.am b/src/dv/Makefile.am
new file mode 100644
index 000000000..755f89d59
--- /dev/null
+++ b/src/dv/Makefile.am
@@ -0,0 +1,66 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12plugindir = $(libdir)/gnunet
13
14lib_LTLIBRARIES = libgnunetdv.la
15
16plugin_LTLIBRARIES = libgnunet_plugin_transport_dv.la
17
18libgnunetdv_la_SOURCES = \
19 dv_api.c dv.h
20libgnunetdv_la_LIBADD = \
21 $(top_builddir)/src/util/libgnunetutil.la \
22 $(top_builddir)/src/core/libgnunetcore.la \
23 $(GN_LIBINTL) $(XLIB)
24libgnunetdv_la_LDFLAGS = \
25 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
26 -version-info 0:0:0
27
28
29bin_PROGRAMS = \
30 gnunet-service-dv
31
32gnunet_service_dv_SOURCES = \
33 gnunet-service-dv.c
34gnunet_service_dv_LDADD = \
35 $(top_builddir)/src/dv/libgnunetdv.la \
36 $(top_builddir)/src/util/libgnunetutil.la \
37 $(GN_LIBINTL)
38
39libgnunet_plugin_transport_dv_la_SOURCES = \
40 plugin_transport_dv.c
41libgnunet_plugin_transport_dv_la_LIBADD = \
42 $(top_builddir)/src/hello/libgnunethello.la \
43 $(top_builddir)/src/dv/libgnunetdv.la \
44 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
45 $(top_builddir)/src/util/libgnunetutil.la
46libgnunet_plugin_transport_dv_la_LDFLAGS = \
47 $(GN_PLUGIN_LDFLAGS)
48
49
50#check_PROGRAMS = \
51# test_statistics_api
52
53TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
54
55#test_statistics_api_SOURCES = \
56# test_statistics_api.c
57#test_statistics_api_LDADD = \
58# $(top_builddir)/src/statistics/libgnunetstatistics.la \
59# $(top_builddir)/src/util/libgnunetutil.la
60
61#EXTRA_DIST = \
62# test_statistics_api_data.conf
63
64#check_SCRIPTS = \
65# test_gnunet_statistics.sh
66