aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-11-24 22:49:37 +0000
committerChristian Grothoff <christian@grothoff.org>2012-11-24 22:49:37 +0000
commit36af7ef06904dfeb143ffe322caac8ab09cedd70 (patch)
treeb5a60725de659179c62b808a18f7365af507548b /src/fs/Makefile.am
parent8a5f6d9ccecf75d0faf56dd0d3b6c48a9041275d (diff)
downloadgnunet-36af7ef06904dfeb143ffe322caac8ab09cedd70.tar.gz
gnunet-36af7ef06904dfeb143ffe322caac8ab09cedd70.zip
combining test_fs_download.c and test_fs_download_index.c into one file, adding additional test test_fs_download_stream
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 419e878d6..2164f9c6c 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -215,6 +215,7 @@ check_PROGRAMS = \
215 test_plugin_block_fs \ 215 test_plugin_block_fs \
216 test_fs_directory \ 216 test_fs_directory \
217 test_fs_download \ 217 test_fs_download \
218 test_fs_download_stream \
218 test_fs_download_indexed \ 219 test_fs_download_indexed \
219 test_fs_download_persistence \ 220 test_fs_download_persistence \
220 test_fs_file_information \ 221 test_fs_file_information \
@@ -300,12 +301,19 @@ test_fs_download_LDADD = \
300 $(top_builddir)/src/util/libgnunetutil.la 301 $(top_builddir)/src/util/libgnunetutil.la
301 302
302test_fs_download_indexed_SOURCES = \ 303test_fs_download_indexed_SOURCES = \
303 test_fs_download_indexed.c 304 test_fs_download.c
304test_fs_download_indexed_LDADD = \ 305test_fs_download_indexed_LDADD = \
305 $(top_builddir)/src/testing/libgnunettesting.la \ 306 $(top_builddir)/src/testing/libgnunettesting.la \
306 $(top_builddir)/src/fs/libgnunetfs.la \ 307 $(top_builddir)/src/fs/libgnunetfs.la \
307 $(top_builddir)/src/util/libgnunetutil.la 308 $(top_builddir)/src/util/libgnunetutil.la
308 309
310test_fs_download_stream_SOURCES = \
311 test_fs_download.c
312test_fs_download_stream_LDADD = \
313 $(top_builddir)/src/testing/libgnunettesting.la \
314 $(top_builddir)/src/fs/libgnunetfs.la \
315 $(top_builddir)/src/util/libgnunetutil.la
316
309test_fs_download_persistence_SOURCES = \ 317test_fs_download_persistence_SOURCES = \
310 test_fs_download_persistence.c 318 test_fs_download_persistence.c
311test_fs_download_persistence_LDADD = \ 319test_fs_download_persistence_LDADD = \
@@ -494,6 +502,8 @@ EXTRA_DIST = \
494 fs_test_lib_data.conf \ 502 fs_test_lib_data.conf \
495 test_fs_data.conf \ 503 test_fs_data.conf \
496 test_fs_download_data.conf \ 504 test_fs_download_data.conf \
505 test_fs_download_index.conf \
506 test_fs_download_stream.conf \
497 test_fs_file_information_data.conf \ 507 test_fs_file_information_data.conf \
498 fs_test_lib_data.conf \ 508 fs_test_lib_data.conf \
499 test_fs_list_indexed_data.conf \ 509 test_fs_list_indexed_data.conf \