aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-09-20 10:10:04 +0000
committerChristian Grothoff <christian@grothoff.org>2012-09-20 10:10:04 +0000
commit1aa42a97fb4310dd72a31aad114b6ebe26aebd8a (patch)
treeed076a8a4dd413efa4cbd67ec6482834b7ebc581 /src/gns/Makefile.am
parent37c4704049df39026b5fb043bcebcd7a15ecf1a2 (diff)
downloadgnunet-1aa42a97fb4310dd72a31aad114b6ebe26aebd8a.tar.gz
gnunet-1aa42a97fb4310dd72a31aad114b6ebe26aebd8a.zip
-core review
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am290
1 files changed, 154 insertions, 136 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 12d50481a..9f732257b 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -6,6 +6,14 @@ endif
6 6
7SUBDIRS = . $(NSS_SUBDIR) 7SUBDIRS = . $(NSS_SUBDIR)
8 8
9EXTRA_DIST = \
10 test_gns_defaults.conf \
11 test_gns_simple_lookup.conf \
12 test_gns_dht_default.conf \
13 zonefiles/188JSUMKEF25GVU8TTV0PBNNN8JVCPUEDFV1UHJJU884JD25V0T0.zkey \
14 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
15 zonefiles/test_zonekey
16
9if MINGW 17if MINGW
10 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 18 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
11 DO_W32_HELPER = gnunet-gns-helper-service-w32 19 DO_W32_HELPER = gnunet-gns-helper-service-w32
@@ -18,7 +26,7 @@ if USE_COVERAGE
18 AM_CFLAGS = --coverage -O0 26 AM_CFLAGS = --coverage -O0
19endif 27endif
20 28
21pkgcfgdir= $(pkgdatadir)/config.d/ 29pkgcfgdir = $(pkgdatadir)/config.d/
22 30
23plugindir = $(libdir)/gnunet 31plugindir = $(libdir)/gnunet
24 32
@@ -28,7 +36,9 @@ pkgcfg_DATA = \
28 36
29lib_LTLIBRARIES = \ 37lib_LTLIBRARIES = \
30 $(DO_W32_NSP) \ 38 $(DO_W32_NSP) \
31 libgnunetgns.la 39 libgnunetgns.la \
40 libgnunetgns_common.la
41
32 42
33if HAVE_MHD 43if HAVE_MHD
34 DO_FCFSD=gnunet-gns-fcfsd 44 DO_FCFSD=gnunet-gns-fcfsd
@@ -46,7 +56,143 @@ bin_PROGRAMS = \
46 gnunet-gns \ 56 gnunet-gns \
47 gnunet-dns2gns 57 gnunet-dns2gns
48 58
49bin_SCRIPTS=gnunet-gns-proxy-setup-ca 59bin_SCRIPTS = gnunet-gns-proxy-setup-ca
60
61plugin_LTLIBRARIES = \
62 libgnunet_plugin_block_gns.la
63
64gnunet_gns_SOURCES = \
65 gnunet-gns.c
66gnunet_gns_LDADD = \
67 $(top_builddir)/src/gns/libgnunetgns.la \
68 $(top_builddir)/src/util/libgnunetutil.la \
69 $(top_builddir)/src/namestore/libgnunetnamestore.la \
70 $(GN_LIBINTL)
71gnunet_gns_DEPENDENCIES = \
72 libgnunetgns.la
73
74gnunet_dns2gns_SOURCES = \
75 gnunet-dns2gns.c
76gnunet_dns2gns_LDADD = \
77 $(top_builddir)/src/gns/libgnunetgns.la \
78 $(top_builddir)/src/util/libgnunetutil.la \
79 $(top_builddir)/src/namestore/libgnunetnamestore.la \
80 $(top_builddir)/src/dns/libgnunetdnsparser.la \
81 $(top_builddir)/src/dns/libgnunetdnsstub.la \
82 $(GN_LIBINTL)
83gnunet_dns2gns_DEPENDENCIES = \
84 libgnunetgns.la
85
86gnunet_gns_proxy_SOURCES = \
87 gnunet-gns-proxy.c gns_proxy_proto.h
88gnunet_gns_proxy_LDADD = -lmicrohttpd -lcurl -lgnutls \
89 $(top_builddir)/src/gns/libgnunetgns.la \
90 $(top_builddir)/src/util/libgnunetutil.la \
91 $(GN_LIBINTL)
92gnunet_gns_proxy_DEPENDENCIES = \
93 libgnunetgns.la
94
95gnunet_gns_helper_service_w32_SOURCES = \
96 gnunet-gns-helper-service-w32.c
97gnunet_gns_helper_service_w32_LDADD = \
98 $(top_builddir)/src/gns/libgnunetgns.la \
99 $(top_builddir)/src/util/libgnunetutil.la \
100 $(GN_LIBINTL)
101gnunet_gns_helper_service_w32_DEPENDENCIES = \
102 libgnunetgns.la
103
104w32nsp_install_SOURCES = \
105 w32nsp-install.c
106w32nsp_install_LDADD = -lws2_32
107
108w32nsp_uninstall_SOURCES = \
109 w32nsp-uninstall.c
110w32nsp_uninstall_LDADD = -lws2_32
111
112w32nsp_resolve_SOURCES = \
113 w32nsp-resolve.c
114w32nsp_resolve_LDADD = -lws2_32
115
116gnunet_service_gns_SOURCES = \
117 gnunet-service-gns.c \
118 gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \
119 gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h
120gnunet_service_gns_LDADD = \
121 -lm \
122 $(top_builddir)/src/statistics/libgnunetstatistics.la \
123 $(top_builddir)/src/util/libgnunetutil.la \
124 $(top_builddir)/src/gns/libgnunetgns_common.la \
125 $(top_builddir)/src/dns/libgnunetdns.la \
126 $(top_builddir)/src/dns/libgnunetdnsparser.la \
127 $(top_builddir)/src/dht/libgnunetdht.la \
128 $(top_builddir)/src/namestore/libgnunetnamestore.la \
129 $(top_builddir)/src/vpn/libgnunetvpn.la \
130 $(GN_LIBINTL)
131gnunet_service_gns_DEPENDENCIES = \
132 $(top_builddir)/src/statistics/libgnunetstatistics.la \
133 $(top_builddir)/src/util/libgnunetutil.la \
134 $(top_builddir)/src/gns/libgnunetgns_common.la \
135 $(top_builddir)/src/dns/libgnunetdns.la \
136 $(top_builddir)/src/dns/libgnunetdnsparser.la \
137 $(top_builddir)/src/dht/libgnunetdht.la \
138 $(top_builddir)/src/namestore/libgnunetnamestore.la \
139 $(top_builddir)/src/vpn/libgnunetvpn.la
140
141
142
143gnunet_gns_fcfsd_SOURCES = \
144 gnunet-gns-fcfsd.c
145gnunet_gns_fcfsd_LDADD = -lmicrohttpd \
146 $(top_builddir)/src/util/libgnunetutil.la \
147 $(top_builddir)/src/namestore/libgnunetnamestore.la \
148 $(GN_LIBINTL)
149gnunet_gns_fcfsd_DEPENDENCIES = \
150 $(top_builddir)/src/util/libgnunetutil.la \
151 $(top_builddir)/src/namestore/libgnunetnamestore.la
152
153libw32nsp_la_SOURCES = \
154 w32nsp.c
155libw32nsp_la_LIBADD = \
156 -lole32 -lws2_32
157libw32nsp_la_LDFLAGS = \
158 -export-symbols $(top_srcdir)/src/gns/w32nsp.def \
159 $(GN_LIB_LDFLAGS)
160
161libgnunetgns_la_SOURCES = \
162 gns_api.c gns.h
163libgnunetgns_la_LIBADD = \
164 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
165 $(top_builddir)/src/namestore/libgnunetnamestore.la
166libgnunetgns_la_LDFLAGS = \
167 $(GN_LIB_LDFLAGS)
168libgnunetgns_la_DEPENDENCIES = \
169 $(top_builddir)/src/util/libgnunetutil.la \
170 $(top_builddir)/src/namestore/libgnunetnamestore.la
171
172
173libgnunetgns_common_la_SOURCES = \
174 gns_common.c gns_common.h
175libgnunetgns_common_la_LIBADD = \
176 $(top_builddir)/src/util/libgnunetutil.la
177libgnunetgns_common_la_DEPENDENCIES = \
178 $(top_builddir)/src/util/libgnunetutil.la
179
180
181libgnunet_plugin_block_gns_la_SOURCES = \
182 plugin_block_gns.c
183libgnunet_plugin_block_gns_la_LIBADD = \
184 $(top_builddir)/src/util/libgnunetutil.la \
185 $(top_builddir)/src/block/libgnunetblock.la \
186 $(top_builddir)/src/gns/libgnunetgns_common.la \
187 $(top_builddir)/src/namestore/libgnunetnamestore.la
188libgnunet_plugin_block_gns_la_LDFLAGS = \
189 $(GN_PLUGIN_LDFLAGS)
190libgnunet_plugin_block_gns_la_DEPENDENCIES = \
191 $(top_builddir)/src/util/libgnunetutil.la \
192 $(top_builddir)/src/gns/libgnunetgns_common.la \
193 $(top_builddir)/src/block/libgnunetblock.la \
194 $(top_builddir)/src/namestore/libgnunetnamestore.la
195
50 196
51check_PROGRAMS = \ 197check_PROGRAMS = \
52 test_gns_simple_shorten \ 198 test_gns_simple_shorten \
@@ -65,7 +211,11 @@ check_PROGRAMS = \
65 test_gns_dht_three_peers 211 test_gns_dht_three_peers
66 #test_gns_proxy 212 #test_gns_proxy
67 213
68 214if ENABLE_TEST_RUN
215if LINUX
216TESTS = $(check_PROGRAMS)
217endif
218endif
69 219
70 220
71# test_gns_simple_lookup 221# test_gns_simple_lookup
@@ -73,9 +223,6 @@ check_PROGRAMS = \
73# test_gns_dht_delegated_lookup 223# test_gns_dht_delegated_lookup
74 224
75 225
76plugin_LTLIBRARIES = \
77 libgnunet_plugin_block_gns.la
78
79#test_gns_proxy_SOURCES = \ 226#test_gns_proxy_SOURCES = \
80# test_gns_proxy.c 227# test_gns_proxy.c
81#test_gns_proxy_LDADD = -lmicrohttpd @LIBCURL@ \ 228#test_gns_proxy_LDADD = -lmicrohttpd @LIBCURL@ \
@@ -282,123 +429,6 @@ test_gns_revocation_DEPENDENCIES = \
282 $(top_builddir)/src/testing/libgnunettesting.la 429 $(top_builddir)/src/testing/libgnunettesting.la
283 430
284 431
285gnunet_gns_SOURCES = \
286 gnunet-gns.c
287gnunet_gns_LDADD = \
288 $(top_builddir)/src/gns/libgnunetgns.la \
289 $(top_builddir)/src/util/libgnunetutil.la \
290 $(top_builddir)/src/namestore/libgnunetnamestore.la \
291 $(GN_LIBINTL)
292gnunet_gns_DEPENDENCIES = \
293 libgnunetgns.la
294
295gnunet_dns2gns_SOURCES = \
296 gnunet-dns2gns.c
297gnunet_dns2gns_LDADD = \
298 $(top_builddir)/src/gns/libgnunetgns.la \
299 $(top_builddir)/src/util/libgnunetutil.la \
300 $(top_builddir)/src/namestore/libgnunetnamestore.la \
301 $(top_builddir)/src/dns/libgnunetdnsparser.la \
302 $(top_builddir)/src/dns/libgnunetdnsstub.la \
303 $(GN_LIBINTL)
304gnunet_dns2gns_DEPENDENCIES = \
305 libgnunetgns.la
306
307gnunet_gns_proxy_SOURCES = \
308 gnunet-gns-proxy.c gns_proxy_proto.h
309gnunet_gns_proxy_LDADD = -lmicrohttpd -lcurl -lgnutls \
310 $(top_builddir)/src/gns/libgnunetgns.la \
311 $(top_builddir)/src/util/libgnunetutil.la \
312 $(GN_LIBINTL)
313gnunet_gns_proxy_DEPENDENCIES = \
314 libgnunetgns.la
315
316gnunet_gns_helper_service_w32_SOURCES = \
317 gnunet-gns-helper-service-w32.c
318gnunet_gns_helper_service_w32_LDADD = \
319 $(top_builddir)/src/gns/libgnunetgns.la \
320 $(top_builddir)/src/util/libgnunetutil.la \
321 $(GN_LIBINTL)
322gnunet_gns_helper_service_w32_DEPENDENCIES = \
323 libgnunetgns.la
324
325w32nsp_install_SOURCES = \
326 w32nsp-install.c
327w32nsp_install_LDADD = -lws2_32
328
329w32nsp_uninstall_SOURCES = \
330 w32nsp-uninstall.c
331w32nsp_uninstall_LDADD = -lws2_32
332
333w32nsp_resolve_SOURCES = \
334 w32nsp-resolve.c
335w32nsp_resolve_LDADD = -lws2_32
336
337gnunet_service_gns_SOURCES = \
338 gnunet-service-gns.c \
339 gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \
340 gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h
341gnunet_service_gns_LDADD = \
342 -lm \
343 $(top_builddir)/src/statistics/libgnunetstatistics.la \
344 $(top_builddir)/src/util/libgnunetutil.la \
345 $(top_builddir)/src/dns/libgnunetdns.la \
346 $(top_builddir)/src/dns/libgnunetdnsparser.la \
347 $(top_builddir)/src/dht/libgnunetdht.la \
348 $(top_builddir)/src/namestore/libgnunetnamestore.la \
349 $(top_builddir)/src/vpn/libgnunetvpn.la \
350 $(GN_LIBINTL)
351gnunet_service_gns_DEPENDENCIES = \
352 $(top_builddir)/src/statistics/libgnunetstatistics.la \
353 $(top_builddir)/src/util/libgnunetutil.la \
354 $(top_builddir)/src/dns/libgnunetdns.la \
355 $(top_builddir)/src/dns/libgnunetdnsparser.la \
356 $(top_builddir)/src/dht/libgnunetdht.la \
357 $(top_builddir)/src/namestore/libgnunetnamestore.la \
358 $(top_builddir)/src/vpn/libgnunetvpn.la
359
360
361gnunet_gns_fcfsd_SOURCES = \
362 gnunet-gns-fcfsd.c
363gnunet_gns_fcfsd_LDADD = -lmicrohttpd \
364 $(top_builddir)/src/util/libgnunetutil.la \
365 $(top_builddir)/src/namestore/libgnunetnamestore.la \
366 $(GN_LIBINTL)
367gnunet_gns_fcfsd_DEPENDENCIES = \
368 $(top_builddir)/src/util/libgnunetutil.la \
369 $(top_builddir)/src/namestore/libgnunetnamestore.la
370
371libw32nsp_la_SOURCES = \
372 w32nsp.c
373libw32nsp_la_LIBADD = \
374 -lole32 -lws2_32
375libw32nsp_la_LDFLAGS = \
376 -export-symbols $(top_srcdir)/src/gns/w32nsp.def \
377 $(GN_LIB_LDFLAGS)
378
379libgnunetgns_la_SOURCES = \
380 gns_api.c gns.h
381libgnunetgns_la_LIBADD = \
382 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
383 $(top_builddir)/src/namestore/libgnunetnamestore.la
384libgnunetgns_la_LDFLAGS = \
385 $(GN_LIB_LDFLAGS)
386libgnunetgns_la_DEPENDENCIES = \
387 $(top_builddir)/src/util/libgnunetutil.la \
388 $(top_builddir)/src/namestore/libgnunetnamestore.la
389
390libgnunet_plugin_block_gns_la_SOURCES = \
391 plugin_block_gns.c
392libgnunet_plugin_block_gns_la_LIBADD = \
393 $(top_builddir)/src/util/libgnunetutil.la \
394 $(top_builddir)/src/block/libgnunetblock.la \
395 $(top_builddir)/src/namestore/libgnunetnamestore.la
396libgnunet_plugin_block_gns_la_LDFLAGS = \
397 $(GN_PLUGIN_LDFLAGS)
398libgnunet_plugin_block_gns_la_DEPENDENCIES = \
399 $(top_builddir)/src/util/libgnunetutil.la \
400 $(top_builddir)/src/block/libgnunetblock.la \
401 $(top_builddir)/src/namestore/libgnunetnamestore.la
402 432
403#Build stub api 433#Build stub api
404#libgnunetnamestore_la_SOURCES = \ 434#libgnunetnamestore_la_SOURCES = \
@@ -410,17 +440,5 @@ libgnunet_plugin_block_gns_la_DEPENDENCIES = \
410#libgnunetnamestore_la_DEPENDENCIES = \ 440#libgnunetnamestore_la_DEPENDENCIES = \
411# $(top_builddir)/src/util/libgnunetutil.la 441# $(top_builddir)/src/util/libgnunetutil.la
412 442
413if ENABLE_TEST_RUN
414if LINUX
415TESTS = $(check_PROGRAMS)
416endif
417endif
418 443
419EXTRA_DIST = \
420 test_gns_defaults.conf \
421 test_gns_simple_lookup.conf \
422 test_gns_dht_default.conf \
423 zonefiles/188JSUMKEF25GVU8TTV0PBNNN8JVCPUEDFV1UHJJU884JD25V0T0.zkey \
424 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
425 zonefiles/test_zonekey
426 444