aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2019-01-25 20:52:55 +0100
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-01-25 20:52:55 +0100
commit7f666b4467ae5f530e904675df3f28886f4202fa (patch)
tree7bceb77a3b5de5fc8ec48bf8211d8bcd239f08fb /src/gns/Makefile.am
parent92d1fd704da83c27e9aac3d385b8dd6cf0c18a8a (diff)
downloadgnunet-7f666b4467ae5f530e904675df3f28886f4202fa.tar.gz
gnunet-7f666b4467ae5f530e904675df3f28886f4202fa.zip
Fix #5514; Add test for GNS Proxy and DANE; Fix TLS connections on ports != 443 through proxy
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index e0497b11e..1abc57d57 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -155,6 +155,12 @@ if HAVE_GNUTLS_DANE
155gnunet_gns_proxy_LDADD += -lgnutls-dane 155gnunet_gns_proxy_LDADD += -lgnutls-dane
156endif 156endif
157 157
158test_gns_proxy_SOURCES = \
159 test_gns_proxy.c
160test_gns_proxy_LDADD = -lmicrohttpd $(LIB_GNURL) -lgnutls \
161 $(top_builddir)/src/util/libgnunetutil.la \
162 $(GN_LIBINTL)
163
158gnunet_gns_helper_service_w32_SOURCES = \ 164gnunet_gns_helper_service_w32_SOURCES = \
159 gnunet-gns-helper-service-w32.c 165 gnunet-gns-helper-service-w32.c
160gnunet_gns_helper_service_w32_LDADD = \ 166gnunet_gns_helper_service_w32_LDADD = \
@@ -232,6 +238,8 @@ libgnunet_plugin_block_gns_la_LIBADD = \
232libgnunet_plugin_block_gns_la_LDFLAGS = \ 238libgnunet_plugin_block_gns_la_LDFLAGS = \
233 $(GN_PLUGIN_LDFLAGS) 239 $(GN_PLUGIN_LDFLAGS)
234 240
241check_PROGRAMS = \
242 test_gns_proxy
235 243
236check_SCRIPTS = \ 244check_SCRIPTS = \
237 test_gns_lookup.sh \ 245 test_gns_lookup.sh \
@@ -248,7 +256,8 @@ check_SCRIPTS = \
248 test_gns_rel_expiration.sh\ 256 test_gns_rel_expiration.sh\
249 test_gns_soa_lookup.sh\ 257 test_gns_soa_lookup.sh\
250 test_gns_revocation.sh\ 258 test_gns_revocation.sh\
251 test_gns_cname_lookup.sh 259 test_gns_cname_lookup.sh \
260 test_proxy.sh
252 261
253if ENABLE_TEST_RUN 262if ENABLE_TEST_RUN
254if HAVE_SQLITE 263if HAVE_SQLITE