aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2012-06-19 14:32:19 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2012-06-19 14:32:19 +0000
commitee6bf88ca9daa63306559c12c2bdc9dedb78a91b (patch)
tree5722149e60ce688a5fd7402241720aca6f7a382c /src/gns/Makefile.am
parent809906cfb208342b0894dbbfa3cb43a102caa42f (diff)
downloadgnunet-ee6bf88ca9daa63306559c12c2bdc9dedb78a91b.tar.gz
gnunet-ee6bf88ca9daa63306559c12c2bdc9dedb78a91b.zip
-ns tests, fixes
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 648b80df9..718257bfd 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -50,7 +50,8 @@ check_PROGRAMS = \
50 test_gns_pseu_shorten \ 50 test_gns_pseu_shorten \
51 test_gns_max_queries \ 51 test_gns_max_queries \
52 test_gns_dht_threepeer \ 52 test_gns_dht_threepeer \
53 test_gns_cname_lookup 53 test_gns_cname_lookup \
54 test_gns_ns_lookup
54 55
55 56
56# test_gns_simple_lookup 57# test_gns_simple_lookup
@@ -210,6 +211,20 @@ test_gns_cname_lookup_DEPENDENCIES = \
210 $(top_builddir)/src/gns/libgnunetgns.la \ 211 $(top_builddir)/src/gns/libgnunetgns.la \
211 $(top_builddir)/src/testing_old/libgnunettesting_old.la 212 $(top_builddir)/src/testing_old/libgnunettesting_old.la
212 213
214
215test_gns_ns_lookup_SOURCES = \
216 test_gns_ns_lookup.c
217test_gns_ns_lookup_LDADD = \
218 $(top_builddir)/src/util/libgnunetutil.la \
219 $(top_builddir)/src/namestore/libgnunetnamestore.la \
220 $(top_builddir)/src/gns/libgnunetgns.la \
221 $(top_builddir)/src/testing_old/libgnunettesting_old.la
222test_gns_ns_lookup_DEPENDENCIES = \
223 $(top_builddir)/src/util/libgnunetutil.la \
224 $(top_builddir)/src/namestore/libgnunetnamestore.la \
225 $(top_builddir)/src/gns/libgnunetgns.la \
226 $(top_builddir)/src/testing_old/libgnunettesting_old.la
227
213gnunet_gns_SOURCES = \ 228gnunet_gns_SOURCES = \
214 gnunet-gns.c 229 gnunet-gns.c
215gnunet_gns_LDADD = \ 230gnunet_gns_LDADD = \
@@ -306,5 +321,7 @@ endif
306EXTRA_DIST = \ 321EXTRA_DIST = \
307 test_gns_defaults.conf \ 322 test_gns_defaults.conf \
308 test_gns_simple_lookup.conf \ 323 test_gns_simple_lookup.conf \
309 test_gns_dht_default.conf 324 test_gns_dht_default.conf \
325 zonefiles/188JSUMKEF25GVU8TTV0PBNNN8JVCPUEDFV1UHJJU884JD25V0T0.zkey \
326 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey
310 327