aboutsummaryrefslogtreecommitdiff
path: root/src/gns/meson.build
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-09-24 10:45:35 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-09-24 10:45:35 +0200
commit3ee4f3c6fb9986fcb67de0cb0bb32d6f12ab44cf (patch)
tree2363b310f35bdb47a8324031a39fc60ce5497006 /src/gns/meson.build
parentf02d9a27000aec7eb424eda767e14b4edbc77efb (diff)
downloadgnunet-3ee4f3c6fb9986fcb67de0cb0bb32d6f12ab44cf.tar.gz
gnunet-3ee4f3c6fb9986fcb67de0cb0bb32d6f12ab44cf.zip
BUILD: meson install headers
Diffstat (limited to 'src/gns/meson.build')
-rw-r--r--src/gns/meson.build48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/gns/meson.build b/src/gns/meson.build
index fa6837a4b..d662ae9c8 100644
--- a/src/gns/meson.build
+++ b/src/gns/meson.build
@@ -33,6 +33,15 @@ libgnunetgns_dep = declare_dependency(link_with : libgnunetgns)
33pkg.generate(libgnunetgns, url: 'https://www.gnunet.org', 33pkg.generate(libgnunetgns, url: 'https://www.gnunet.org',
34 description : 'Provides API to access the GNU Name System') 34 description : 'Provides API to access the GNU Name System')
35 35
36shared_module('gnunet_plugin_gnsrecord_gns',
37 ['plugin_gnsrecord_gns.c'],
38 dependencies: [libgnunetutil_dep,
39 libgnunetgnsrecord_dep,
40 libgnunetidentity_dep],
41 include_directories: [incdir, configuration_inc],
42 install: true,
43 install_dir: get_option('libdir')/'gnunet')
44
36 45
37executable ('gnunet-gns', 46executable ('gnunet-gns',
38 'gnunet-gns.c', 47 'gnunet-gns.c',
@@ -55,6 +64,7 @@ executable ('gnunet-gns-proxy',
55 include_directories: [incdir, configuration_inc], 64 include_directories: [incdir, configuration_inc],
56 install: true, 65 install: true,
57 install_dir: get_option('libdir') / 'gnunet' / 'libexec') 66 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
67
58executable ('gnunet-service-gns', 68executable ('gnunet-service-gns',
59 gnunetservicegns_src, 69 gnunetservicegns_src,
60 dependencies: [libgnunetgns_dep, 70 dependencies: [libgnunetgns_dep,
@@ -73,3 +83,41 @@ executable ('gnunet-service-gns',
73 include_directories: [incdir, configuration_inc], 83 include_directories: [incdir, configuration_inc],
74 install: true, 84 install: true,
75 install_dir: get_option('libdir') / 'gnunet' / 'libexec') 85 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
86executable ('gnunet-bcd',
87 ['gnunet-bcd.c'],
88 dependencies: [libgnunetgns_dep,
89 libgnunetutil_dep,
90 libgnunetstatistics_dep,
91 libgnunetcore_dep,
92 libgnunetdht_dep,
93 libgnunetdns_dep,
94 mhd_dep,
95 idn_dep,
96 libgnunetidentity_dep,
97 libgnunetnamecache_dep,
98 libgnunetrevocation_dep,
99 libgnunetgnsrecord_dep,
100 libgnunetcadet_dep,
101 libgnunetblock_dep],
102 include_directories: [incdir, configuration_inc],
103 install: true,
104 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
105executable ('gnunet-dns2gns',
106 ['gnunet-dns2gns.c'],
107 dependencies: [libgnunetgns_dep,
108 libgnunetutil_dep,
109 libgnunetstatistics_dep,
110 libgnunetvpn_dep,
111 libgnunetcore_dep,
112 libgnunetdht_dep,
113 libgnunetdns_dep,
114 idn_dep,
115 libgnunetidentity_dep,
116 libgnunetnamecache_dep,
117 libgnunetrevocation_dep,
118 libgnunetgnsrecord_dep,
119 libgnunetcadet_dep,
120 libgnunetblock_dep],
121 include_directories: [incdir, configuration_inc],
122 install: true,
123 install_dir: get_option('libdir') / 'gnunet' / 'libexec')