aboutsummaryrefslogtreecommitdiff
path: root/src/hostlist/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2010-04-22 08:29:36 +0000
committerChristian Grothoff <christian@grothoff.org>2010-04-22 08:29:36 +0000
commit808e125f5a5a08b41fc4b4234f29008fc5fb8c81 (patch)
treebe6d36c4fe7ff50cf075a0bb5b8d76b235e4cdc8 /src/hostlist/Makefile.am
parent17ed8fb315fc5e426ec26dbb7374485aaf5019f4 (diff)
downloadgnunet-808e125f5a5a08b41fc4b4234f29008fc5fb8c81.tar.gz
gnunet-808e125f5a5a08b41fc4b4234f29008fc5fb8c81.zip
create hostlist client if we have no MHD
Diffstat (limited to 'src/hostlist/Makefile.am')
-rw-r--r--src/hostlist/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/hostlist/Makefile.am b/src/hostlist/Makefile.am
index 7bc9ffd3a..5e67d034c 100644
--- a/src/hostlist/Makefile.am
+++ b/src/hostlist/Makefile.am
@@ -4,6 +4,10 @@ if USE_COVERAGE
4 AM_CFLAGS = --coverage -O0 4 AM_CFLAGS = --coverage -O0
5endif 5endif
6 6
7if HAVE_MHD
8 HOSTLIST_SERVER_SOURCES = hostlist-server.c hostlist-server.h
9 GN_LIBMHD = -lmicrohttpd
10endif
7 11
8bin_PROGRAMS = \ 12bin_PROGRAMS = \
9 gnunet-daemon-hostlist 13 gnunet-daemon-hostlist
@@ -11,7 +15,7 @@ bin_PROGRAMS = \
11gnunet_daemon_hostlist_SOURCES = \ 15gnunet_daemon_hostlist_SOURCES = \
12 gnunet-daemon-hostlist.c gnunet-daemon-hostlist.h \ 16 gnunet-daemon-hostlist.c gnunet-daemon-hostlist.h \
13 hostlist-client.c hostlist-client.h \ 17 hostlist-client.c hostlist-client.h \
14 hostlist-server.c hostlist-server.h 18 $(HOSTLIST_SERVER_SOURCES)
15 19
16gnunet_daemon_hostlist_LDADD = \ 20gnunet_daemon_hostlist_LDADD = \
17 $(top_builddir)/src/core/libgnunetcore.la \ 21 $(top_builddir)/src/core/libgnunetcore.la \
@@ -20,7 +24,7 @@ gnunet_daemon_hostlist_LDADD = \
20 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 24 $(top_builddir)/src/statistics/libgnunetstatistics.la \
21 $(top_builddir)/src/transport/libgnunettransport.la \ 25 $(top_builddir)/src/transport/libgnunettransport.la \
22 $(top_builddir)/src/util/libgnunetutil.la \ 26 $(top_builddir)/src/util/libgnunetutil.la \
23 -lmicrohttpd \ 27 $(GN_LIBMHD) \
24 @LIBCURL@ \ 28 @LIBCURL@ \
25 $(GN_LIBINTL) 29 $(GN_LIBINTL)
26 30
@@ -31,9 +35,10 @@ check_PROGRAMS = \
31 test_gnunet_daemon_hostlist \ 35 test_gnunet_daemon_hostlist \
32 test_gnunet_daemon_hostlist_learning 36 test_gnunet_daemon_hostlist_learning
33 37
34 38if HAVE_MHD
35TESTS = test_gnunet_daemon_hostlist \ 39TESTS = test_gnunet_daemon_hostlist \
36 test_gnunet_daemon_hostlist_learning 40 test_gnunet_daemon_hostlist_learning
41endif
37 42
38test_gnunet_daemon_hostlist_SOURCES = \ 43test_gnunet_daemon_hostlist_SOURCES = \
39 test_gnunet_daemon_hostlist.c 44 test_gnunet_daemon_hostlist.c
@@ -48,7 +53,7 @@ test_gnunet_daemon_hostlist_learning_LDADD = \
48 $(top_builddir)/src/transport/libgnunettransport.la \ 53 $(top_builddir)/src/transport/libgnunettransport.la \
49 $(top_builddir)/src/arm/libgnunetarm.la \ 54 $(top_builddir)/src/arm/libgnunetarm.la \
50 $(top_builddir)/src/core/libgnunetcore.la \ 55 $(top_builddir)/src/core/libgnunetcore.la \
51 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 56 $(top_builddir)/src/statistics/libgnunetstatistics.la \
52 $(top_builddir)/src/util/libgnunetutil.la 57 $(top_builddir)/src/util/libgnunetutil.la
53 58
54EXTRA_DIST = \ 59EXTRA_DIST = \