aboutsummaryrefslogtreecommitdiff
path: root/src/identity-provider/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2016-01-07 21:10:24 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2016-01-07 21:10:24 +0000
commit1b67c9c5424c96ff4e30d12b8d58cec315f000a1 (patch)
tree65a03cf96bd718d3e57bd2d7f0f0a648cb1986f4 /src/identity-provider/Makefile.am
parent4c2b05fe49e5ee49c69337e763a3572af59e78d5 (diff)
downloadgnunet-1b67c9c5424c96ff4e30d12b8d58cec315f000a1.tar.gz
gnunet-1b67c9c5424c96ff4e30d12b8d58cec315f000a1.zip
- Finish refactoring
Diffstat (limited to 'src/identity-provider/Makefile.am')
-rw-r--r--src/identity-provider/Makefile.am70
1 files changed, 70 insertions, 0 deletions
diff --git a/src/identity-provider/Makefile.am b/src/identity-provider/Makefile.am
new file mode 100644
index 000000000..a9338ba59
--- /dev/null
+++ b/src/identity-provider/Makefile.am
@@ -0,0 +1,70 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4 plugindir = $(libdir)/gnunet
5
6if MINGW
7 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
8endif
9
10if USE_COVERAGE
11 AM_CFLAGS = --coverage -O0
12 XLIB = -lgcov
13endif
14
15pkgcfgdir= $(pkgdatadir)/config.d/
16
17libexecdir= $(pkglibdir)/libexec/
18
19pkgcfg_DATA = \
20 identity-token.conf
21
22plugin_LTLIBRARIES = \
23 libgnunet_plugin_rest_identity_token.la
24lib_LTLIBRARIES = \
25 libgnunetidentityprovider.la
26
27bin_PROGRAMS = \
28 gnunet-identity-token
29
30libexec_PROGRAMS = \
31 gnunet-service-identity-token
32
33gnunet_service_identity_token_SOURCES = \
34 gnunet-service-identity-token.c
35gnunet_service_identity_token_LDADD = \
36 libgnunetidentityprovider.la \
37 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
38 $(top_builddir)/src/util/libgnunetutil.la \
39 $(top_builddir)/src/namestore/libgnunetnamestore.la \
40 $(top_builddir)/src/identity/libgnunetidentity.la \
41 $(GN_LIBINTL) \
42 -ljansson
43
44libgnunetidentityprovider_la_SOURCES = \
45 identity-token.c
46libgnunetidentityprovider_la_LIBADD = \
47 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
48 $(LTLIBINTL) -ljansson
49
50libgnunet_plugin_rest_identity_token_la_SOURCES = \
51 plugin_rest_identity_token.c
52libgnunet_plugin_rest_identity_token_la_LIBADD = \
53 $(top_builddir)/src/identity/libgnunetidentity.la \
54 $(top_builddir)/src/rest/libgnunetrest.la \
55 $(top_builddir)/src/namestore/libgnunetnamestore.la \
56 $(top_builddir)/src/gns/libgnunetgns.la \
57 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
58 $(LTLIBINTL) -ljansson -lmicrohttpd
59libgnunet_plugin_rest_identity_token_la_LDFLAGS = \
60 $(GN_PLUGIN_LDFLAGS)
61
62
63gnunet_identity_token_SOURCES = \
64 gnunet-identity-token.c
65gnunet_identity_token_LDADD = \
66 $(top_builddir)/src/util/libgnunetutil.la \
67 -ljansson -lmicrohttpd \
68 $(GN_LIBINTL)
69
70