aboutsummaryrefslogtreecommitdiff
path: root/src/identity-provider/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2017-10-06 19:31:46 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2017-10-06 19:31:46 +0200
commit8b22f677adfde6212410c5abb2aff27988cc997c (patch)
treed8b6e2bbb48edf875de4ca5284b48261bdab94a2 /src/identity-provider/Makefile.am
parent371458b9ed084c6d510a03c9ea27cb8162f0e87a (diff)
downloadgnunet-8b22f677adfde6212410c5abb2aff27988cc997c.tar.gz
gnunet-8b22f677adfde6212410c5abb2aff27988cc997c.zip
-readd new rest plugin
Diffstat (limited to 'src/identity-provider/Makefile.am')
-rw-r--r--src/identity-provider/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/identity-provider/Makefile.am b/src/identity-provider/Makefile.am
index 0aabc2143..64a54457d 100644
--- a/src/identity-provider/Makefile.am
+++ b/src/identity-provider/Makefile.am
@@ -26,7 +26,8 @@ pkgcfg_DATA = \
26lib_LTLIBRARIES = \ 26lib_LTLIBRARIES = \
27 libgnunetidentityprovider.la 27 libgnunetidentityprovider.la
28plugin_LTLIBRARIES = \ 28plugin_LTLIBRARIES = \
29 libgnunet_plugin_gnsrecord_identity_provider.la \ 29 libgnunet_plugin_rest_identity_provider.la \
30 libgnunet_plugin_gnsrecord_identity_provider.la \
30 $(SQLITE_PLUGIN) 31 $(SQLITE_PLUGIN)
31 32
32bin_PROGRAMS = \ 33bin_PROGRAMS = \
@@ -82,6 +83,19 @@ libgnunetidentityprovider_la_LDFLAGS = \
82 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 83 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
83 -version-info 0:0:0 84 -version-info 0:0:0
84 85
86libgnunet_plugin_rest_identity_provider_la_SOURCES = \
87 plugin_rest_identity_provider.c
88libgnunet_plugin_rest_identity_provider_la_LIBADD = \
89 $(top_builddir)/src/identity/libgnunetidentity.la \
90 libgnunetidentityprovider.la \
91 $(top_builddir)/src/rest/libgnunetrest.la \
92 $(top_builddir)/src/jsonapi/libgnunetjsonapi.la \
93 $(top_builddir)/src/namestore/libgnunetnamestore.la \
94 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
95 $(LTLIBINTL) -ljansson -lmicrohttpd
96libgnunet_plugin_rest_identity_provider_la_LDFLAGS = \
97 $(GN_PLUGIN_LDFLAGS)
98
85gnunet_idp_SOURCES = \ 99gnunet_idp_SOURCES = \
86 gnunet-idp.c 100 gnunet-idp.c
87gnunet_idp_LDADD = \ 101gnunet_idp_LDADD = \