aboutsummaryrefslogtreecommitdiff
path: root/src/json/meson.build
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-10-18 13:49:14 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-10-18 13:49:14 +0200
commit5b2527d8d81f92e00a0835e3039a0a2eee0ee566 (patch)
tree2e1ccc44f46ca7dc675f4938eab0e5e8efaad793 /src/json/meson.build
parent84bbd6f1be6686b3c816ee5bb5c0c786ac193c6c (diff)
downloadgnunet-5b2527d8d81f92e00a0835e3039a0a2eee0ee566.tar.gz
gnunet-5b2527d8d81f92e00a0835e3039a0a2eee0ee566.zip
BUILD: Move json to lib
Diffstat (limited to 'src/json/meson.build')
-rw-r--r--src/json/meson.build25
1 files changed, 0 insertions, 25 deletions
diff --git a/src/json/meson.build b/src/json/meson.build
deleted file mode 100644
index 98385163e..000000000
--- a/src/json/meson.build
+++ /dev/null
@@ -1,25 +0,0 @@
1libgnunetjson_src = ['json.c',
2 'json_generator.c',
3 'json_helper.c',
4 'json_mhd.c',
5 'json_pack.c']
6
7if get_option('monolith')
8 foreach p : libgnunetjson_src
9 gnunet_src += 'json/' + p
10 endforeach
11 subdir_done()
12endif
13
14libgnunetjson = library('gnunetjson',
15 libgnunetjson_src,
16 soversion: '0',
17 version: '0.0.0',
18 dependencies: [libgnunetutil_dep, json_dep, mhd_dep, zlib_dep],
19 include_directories: [incdir, configuration_inc],
20 install: true,
21 install_dir: get_option('libdir'))
22libgnunetjson_dep = declare_dependency(link_with : libgnunetjson)
23pkg.generate(libgnunetjson, url: 'https://www.gnunet.org',
24 description : 'Library for JSON de/serialization')
25