aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2011-09-09 17:19:52 +0000
committerBart Polot <bart@net.in.tum.de>2011-09-09 17:19:52 +0000
commit27c5602e08caa837cf8bfcfe4bb9629f5d76231b (patch)
tree2917c74202177afc58bd1ba47678a82f8b4b971a /src/mesh/Makefile.am
parent9b04e0d667cb4ddec6ead610628406fad88fd30b (diff)
downloadgnunet-27c5602e08caa837cf8bfcfe4bb9629f5d76231b.tar.gz
gnunet-27c5602e08caa837cf8bfcfe4bb9629f5d76231b.zip
Added testcase for explicit case of DHT not finding apptype
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am21
1 files changed, 15 insertions, 6 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 0c7d598d4..1a6852a54 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -48,7 +48,8 @@ libgnunetmeshnew_la_LDFLAGS = \
48 48
49check_PROGRAMS = \ 49check_PROGRAMS = \
50 test_mesh_api \ 50 test_mesh_api \
51 test_mesh_local \ 51 test_mesh_local_1 \
52 test_mesh_local_2 \
52 test_mesh_small 53 test_mesh_small
53 54
54test_mesh_api_SOURCES = \ 55test_mesh_api_SOURCES = \
@@ -59,12 +60,20 @@ test_mesh_api_LDADD = \
59test_mesh_api_DEPENDENCIES = \ 60test_mesh_api_DEPENDENCIES = \
60 libgnunetmeshnew.la 61 libgnunetmeshnew.la
61 62
62test_mesh_local_SOURCES = \ 63test_mesh_local_1_SOURCES = \
63 test_mesh_local.c 64 test_mesh_local_1.c
64test_mesh_local_LDADD = \ 65test_mesh_local_1_LDADD = \
65 $(top_builddir)/src/util/libgnunetutil.la \ 66 $(top_builddir)/src/util/libgnunetutil.la \
66 $(top_builddir)/src/mesh/libgnunetmeshnew.la 67 $(top_builddir)/src/mesh/libgnunetmeshnew.la
67test_mesh_api_DEPENDENCIES = \ 68test_mesh_api_1_DEPENDENCIES = \
69 libgnunetmeshnew.la
70
71test_mesh_local_2_SOURCES = \
72 test_mesh_local_2.c
73test_mesh_local_2_LDADD = \
74 $(top_builddir)/src/util/libgnunetutil.la \
75 $(top_builddir)/src/mesh/libgnunetmeshnew.la
76test_mesh_api_2_DEPENDENCIES = \
68 libgnunetmeshnew.la 77 libgnunetmeshnew.la
69 78
70test_mesh_small_SOURCES = \ 79test_mesh_small_SOURCES = \
@@ -77,7 +86,7 @@ test_mesh_small_DEPENDENCIES = \
77 libgnunetmeshnew.la 86 libgnunetmeshnew.la
78 87
79if ENABLE_TEST_RUN 88if ENABLE_TEST_RUN
80TESTS = test_mesh_api 89TESTS = test_mesh_api test_mesh_local_1 test_mesh_local_2
81endif 90endif
82 91
83EXTRA_DIST = \ 92EXTRA_DIST = \