aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2011-05-06 01:45:13 +0000
committerBart Polot <bart@net.in.tum.de>2011-05-06 01:45:13 +0000
commit3252ddd73ea1639aba2159e7cc91681730470cbf (patch)
tree4a3cb369b49edf9cae76a1469dbac7c44598851d /src/mesh/Makefile.am
parent76dcc3351564146f788e8a354cb3c42025db21cc (diff)
downloadgnunet-3252ddd73ea1639aba2159e7cc91681730470cbf.tar.gz
gnunet-3252ddd73ea1639aba2159e7cc91681730470cbf.zip
WiP
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am26
1 files changed, 24 insertions, 2 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 4bb972f8c..902ed95f9 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -13,7 +13,8 @@ bin_PROGRAMS = $(STUD_PROGS) \
13 gnunet-service-mesh 13 gnunet-service-mesh
14 14
15lib_LTLIBRARIES = \ 15lib_LTLIBRARIES = \
16 libgnunetmesh.la 16 libgnunetmesh.la \
17 libgnunetmeshnew.la
17 18
18libgnunetmesh_la_SOURCES = \ 19libgnunetmesh_la_SOURCES = \
19 mesh_api.c 20 mesh_api.c
@@ -26,10 +27,31 @@ libgnunetmesh_la_LDFLAGS = \
26 -version-info 0:0:0 27 -version-info 0:0:0
27 28
28gnunet_service_mesh_SOURCES = \ 29gnunet_service_mesh_SOURCES = \
29 gnunet-service-mesh.c 30 gnunet-service-mesh.c
30 31
31gnunet_service_mesh_LDADD = \ 32gnunet_service_mesh_LDADD = \
32 $(top_builddir)/src/core/libgnunetcore.la\ 33 $(top_builddir)/src/core/libgnunetcore.la\
33 $(top_builddir)/src/dht/libgnunetdht.la \ 34 $(top_builddir)/src/dht/libgnunetdht.la \
34 $(top_builddir)/src/util/libgnunetutil.la 35 $(top_builddir)/src/util/libgnunetutil.la
35 36
37
38libgnunetmeshnew_la_SOURCES = \
39 mesh_api_new.c mesh.h
40libgnunetmeshnew_la_LIBADD = \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(XLIB)
43libgnunetmeshnew_la_LDFLAGS = \
44 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
45 -version-info 0:0:0
46
47check_PROGRAMS = $(STUD_TESTS) \
48 test_mesh_api
49
50test_mesh_api_SOURCES = \
51 test_mesh_api.c
52test_mesh_api_LDADD = \
53 $(top_builddir)/src/util/libgnunetutil.la \
54 $(top_builddir)/src/mesh/libgnunetmeshnew.la
55test_mesh_api_DEPENDENCIES = \
56 libgnunetmeshnew.la
57