aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2011-09-07 14:38:59 +0000
committerBart Polot <bart@net.in.tum.de>2011-09-07 14:38:59 +0000
commit381046a7d5c92f5ec1b9bf4566eecacfde269099 (patch)
tree07d321493db8f960f4aa2f20218f3dfb1a20fdef /src/mesh/Makefile.am
parent6838672013100731f5bc5451f4157878080beb2d (diff)
downloadgnunet-381046a7d5c92f5ec1b9bf4566eecacfde269099.tar.gz
gnunet-381046a7d5c92f5ec1b9bf4566eecacfde269099.zip
Added new test for multiple clients on one peer
Fixed dumb obvious bug in api
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index cea6152e2..f49b3e326 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -48,14 +48,22 @@ libgnunetmeshnew_la_LDFLAGS = \
48 48
49check_PROGRAMS = \ 49check_PROGRAMS = \
50 test_mesh_api \ 50 test_mesh_api \
51 test_mesh_local \
51 test_mesh_small 52 test_mesh_small
52 53
53test_mesh_api_SOURCES = \ 54test_mesh_api_SOURCES = \
54 test_mesh_api.c 55 test_mesh_api.c
55test_mesh_api_LDADD = \ 56test_mesh_api_LDADD = \
56 $(top_builddir)/src/util/libgnunetutil.la \ 57 $(top_builddir)/src/util/libgnunetutil.la \
57 $(top_builddir)/src/mesh/libgnunetmeshnew.la \ 58 $(top_builddir)/src/mesh/libgnunetmeshnew.la
58 $(top_builddir)/src/dht/libgnunetdht.la 59test_mesh_api_DEPENDENCIES = \
60 libgnunetmeshnew.la
61
62test_mesh_local_SOURCES = \
63 test_mesh_local.c
64test_mesh_local_LDADD = \
65 $(top_builddir)/src/util/libgnunetutil.la \
66 $(top_builddir)/src/mesh/libgnunetmeshnew.la
59test_mesh_api_DEPENDENCIES = \ 67test_mesh_api_DEPENDENCIES = \
60 libgnunetmeshnew.la 68 libgnunetmeshnew.la
61 69
@@ -69,7 +77,7 @@ test_mesh_small_DEPENDENCIES = \
69 libgnunetmeshnew.la 77 libgnunetmeshnew.la
70 78
71if ENABLE_TEST_RUN 79if ENABLE_TEST_RUN
72TESTS = test_mesh_api 80TESTS = test_mesh_api test_mesh_local
73endif 81endif
74 82
75EXTRA_DIST = \ 83EXTRA_DIST = \