aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2011-10-17 11:05:05 +0000
committerBart Polot <bart@net.in.tum.de>2011-10-17 11:05:05 +0000
commit469571975ea9114c835789caf3f4951984374000 (patch)
tree997073234a9e1ff8bd9113f9f2d218409dc101d0 /src/mesh/Makefile.am
parent522e801284ab0a8b39f6e8cc96c0609a0f28e6a8 (diff)
downloadgnunet-469571975ea9114c835789caf3f4951984374000.tar.gz
gnunet-469571975ea9114c835789caf3f4951984374000.zip
Refactored multicast code to allow sending any message as multicast, added multicast testcase copied from unicast
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 391d86f80..2c4dc0b4c 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -56,7 +56,8 @@ check_PROGRAMS = \
56 test_mesh_local_2 \ 56 test_mesh_local_2 \
57 test_mesh_small \ 57 test_mesh_small \
58 test_mesh_small_unicast \ 58 test_mesh_small_unicast \
59 test_mesh_small_unicast_far 59 test_mesh_small_unicast_far \
60 test_mesh_small_multicast
60 61
61test_mesh_api_SOURCES = \ 62test_mesh_api_SOURCES = \
62 test_mesh_api.c 63 test_mesh_api.c
@@ -119,8 +120,18 @@ test_mesh_small_unicast_far_LDADD = \
119test_mesh_small_unicast_far_DEPENDENCIES = \ 120test_mesh_small_unicast_far_DEPENDENCIES = \
120 libgnunetmeshnew.la 121 libgnunetmeshnew.la
121 122
123test_mesh_small_multicast_SOURCES = \
124 test_mesh_small_multicast.c
125test_mesh_small_multicast_LDADD = \
126 $(top_builddir)/src/mesh/libgnunetmeshnew.la \
127 $(top_builddir)/src/util/libgnunetutil.la \
128 $(top_builddir)/src/testing/libgnunettesting.la
129test_mesh_small_multicast_DEPENDENCIES = \
130 libgnunetmeshnew.la
131
132
122if ENABLE_TEST_RUN 133if ENABLE_TEST_RUN
123TESTS = test_mesh_api test_mesh_path_api test_mesh_local_1 test_mesh_local_2 test_mesh_small 134TESTS = test_mesh_api test_mesh_path_api test_mesh_local_1 test_mesh_local_2 test_mesh_small test_mesh_small_unicast
124endif 135endif
125 136
126EXTRA_DIST = \ 137EXTRA_DIST = \