aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2011-10-06 20:25:46 +0000
committerBart Polot <bart@net.in.tum.de>2011-10-06 20:25:46 +0000
commit68f027903ee06b86c56c9f16dba9a83333936dbe (patch)
treecc3427f357b0af46b022f64ffa9db63012209508 /src/mesh/Makefile.am
parentcde214abca5b579930d25dcbf0e95b9062a9a8ea (diff)
downloadgnunet-68f027903ee06b86c56c9f16dba9a83333936dbe.tar.gz
gnunet-68f027903ee06b86c56c9f16dba9a83333936dbe.zip
Added new testcase for connecting two peers on opposite parts of a torus
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index e95faffea..391d86f80 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -55,7 +55,8 @@ check_PROGRAMS = \
55 test_mesh_local_1 \ 55 test_mesh_local_1 \
56 test_mesh_local_2 \ 56 test_mesh_local_2 \
57 test_mesh_small \ 57 test_mesh_small \
58 test_mesh_small_unicast 58 test_mesh_small_unicast \
59 test_mesh_small_unicast_far
59 60
60test_mesh_api_SOURCES = \ 61test_mesh_api_SOURCES = \
61 test_mesh_api.c 62 test_mesh_api.c
@@ -109,6 +110,15 @@ test_mesh_small_unicast_LDADD = \
109test_mesh_small_unicast_DEPENDENCIES = \ 110test_mesh_small_unicast_DEPENDENCIES = \
110 libgnunetmeshnew.la 111 libgnunetmeshnew.la
111 112
113test_mesh_small_unicast_far_SOURCES = \
114 test_mesh_small_unicast_far.c
115test_mesh_small_unicast_far_LDADD = \
116 $(top_builddir)/src/mesh/libgnunetmeshnew.la \
117 $(top_builddir)/src/util/libgnunetutil.la \
118 $(top_builddir)/src/testing/libgnunettesting.la
119test_mesh_small_unicast_far_DEPENDENCIES = \
120 libgnunetmeshnew.la
121
112if ENABLE_TEST_RUN 122if ENABLE_TEST_RUN
113TESTS = test_mesh_api test_mesh_path_api test_mesh_local_1 test_mesh_local_2 test_mesh_small 123TESTS = test_mesh_api test_mesh_path_api test_mesh_local_1 test_mesh_local_2 test_mesh_small
114endif 124endif