aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2011-09-20 12:09:08 +0000
committerBart Polot <bart@net.in.tum.de>2011-09-20 12:09:08 +0000
commit73e047c74d351257f8b6cf0815a56ff650520cc1 (patch)
tree6a0404a888520ae756a2da2259498fc19b5751c4 /src/mesh/Makefile.am
parentdd6f8f750c62c0680528ae4a0744403aa80074be (diff)
downloadgnunet-73e047c74d351257f8b6cf0815a56ff650520cc1.tar.gz
gnunet-73e047c74d351257f8b6cf0815a56ff650520cc1.zip
Added path testcase
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am24
1 files changed, 19 insertions, 5 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index c9960bdec..26f4de7a5 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -30,12 +30,14 @@ libgnunetmesh_la_LDFLAGS = \
30 30
31gnunet_service_mesh_SOURCES = \ 31gnunet_service_mesh_SOURCES = \
32 gnunet-service-mesh.c mesh_tunnel_tree.c 32 gnunet-service-mesh.c mesh_tunnel_tree.c
33
34gnunet_service_mesh_LDADD = \ 33gnunet_service_mesh_LDADD = \
35 $(top_builddir)/src/core/libgnunetcore.la\ 34 $(top_builddir)/src/core/libgnunetcore.la\
36 $(top_builddir)/src/dht/libgnunetdht.la \ 35 $(top_builddir)/src/dht/libgnunetdht.la \
37 $(top_builddir)/src/util/libgnunetutil.la 36 $(top_builddir)/src/util/libgnunetutil.la
38 37 gnunet_service_mesh_DEPENDENCIES = \
38 $(top_builddir)/src/core/libgnunetcore.la\
39 $(top_builddir)/src/dht/libgnunetdht.la \
40 $(top_builddir)/src/util/libgnunetutil.la
39 41
40libgnunetmeshnew_la_SOURCES = \ 42libgnunetmeshnew_la_SOURCES = \
41 mesh_api_new.c mesh.h 43 mesh_api_new.c mesh.h
@@ -48,6 +50,7 @@ libgnunetmeshnew_la_LDFLAGS = \
48 50
49check_PROGRAMS = \ 51check_PROGRAMS = \
50 test_mesh_api \ 52 test_mesh_api \
53 test_mesh_path_api \
51 test_mesh_local_1 \ 54 test_mesh_local_1 \
52 test_mesh_local_2 \ 55 test_mesh_local_2 \
53 test_mesh_small 56 test_mesh_small
@@ -58,7 +61,17 @@ test_mesh_api_LDADD = \
58 $(top_builddir)/src/util/libgnunetutil.la \ 61 $(top_builddir)/src/util/libgnunetutil.la \
59 $(top_builddir)/src/mesh/libgnunetmeshnew.la 62 $(top_builddir)/src/mesh/libgnunetmeshnew.la
60test_mesh_api_DEPENDENCIES = \ 63test_mesh_api_DEPENDENCIES = \
61 libgnunetmeshnew.la 64 libgnunetmeshnew.la \
65 $(top_builddir)/src/util/libgnunetutil.la
66
67test_mesh_path_api_SOURCES = \
68 test_mesh_path_api.c
69test_mesh_path_api_LDADD = \
70 $(top_builddir)/src/util/libgnunetutil.la \
71 $(top_builddir)/src/dht/libgnunetdht.la
72test_mesh_path_api_DEPENDENCIES = \
73 libgnunetmeshnew.la \
74 $(top_builddir)/src/dht/libgnunetdht.la
62 75
63test_mesh_local_1_SOURCES = \ 76test_mesh_local_1_SOURCES = \
64 test_mesh_local_1.c 77 test_mesh_local_1.c
@@ -87,9 +100,10 @@ test_mesh_small_DEPENDENCIES = \
87 100
88if ENABLE_TEST_RUN 101if ENABLE_TEST_RUN
89if HAVE_EXPERIMENTAL 102if HAVE_EXPERIMENTAL
90TESTS = test_mesh_api test_mesh_local_1 test_mesh_local_2 103TESTS = test_mesh_api test_mesh_path_api test_mesh_local_1 test_mesh_local_2
91endif 104endif
92endif 105endif
93 106
94EXTRA_DIST = \ 107EXTRA_DIST = \
95 test_mesh.conf \ No newline at end of file 108 test_mesh.conf \
109 test_mesh_path.conf \ No newline at end of file