aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2013-07-23 13:20:34 +0000
committerBart Polot <bart@net.in.tum.de>2013-07-23 13:20:34 +0000
commit7e240c4e5ae08722f5c6965c9470c8fdf1c793dc (patch)
tree94e6cf909987313a9b995b5dc9bf61163cc43438 /src/mesh/Makefile.am
parent55ccb1af2e04c487b468e828535c863e7e180709 (diff)
downloadgnunet-7e240c4e5ae08722f5c6965c9470c8fdf1c793dc.tar.gz
gnunet-7e240c4e5ae08722f5c6965c9470c8fdf1c793dc.zip
- add separate encryption enabled mesh to avoid breakage during developement
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 7b6142626..f2aacd8a4 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -21,7 +21,7 @@ plugindir = $(libdir)/gnunet
21AM_CLFAGS = -g 21AM_CLFAGS = -g
22 22
23libexec_PROGRAMS = \ 23libexec_PROGRAMS = \
24 gnunet-service-mesh $(EXP_LIBEXEC) 24 gnunet-service-mesh gnunet-service-mesh-enc $(EXP_LIBEXEC)
25 25
26bin_PROGRAMS = \ 26bin_PROGRAMS = \
27 gnunet-mesh 27 gnunet-mesh
@@ -83,6 +83,28 @@ if LINUX
83 gnunet_service_mesh_LDFLAGS = -lrt 83 gnunet_service_mesh_LDFLAGS = -lrt
84endif 84endif
85 85
86gnunet_service_mesh_enc_SOURCES = \
87 gnunet-service-mesh-enc.c \
88 mesh_path.c \
89 mesh_common.c
90gnunet_service_mesh_enc_CFLAGS = $(AM_CFLAGS)
91gnunet_service_mesh_enc_LDADD = \
92 $(top_builddir)/src/util/libgnunetutil.la \
93 $(top_builddir)/src/core/libgnunetcore.la \
94 $(top_builddir)/src/dht/libgnunetdht.la \
95 $(top_builddir)/src/statistics/libgnunetstatistics.la \
96 $(top_builddir)/src/block/libgnunetblock.la
97gnunet_service_mesh_enc_DEPENDENCIES = \
98 $(top_builddir)/src/util/libgnunetutil.la \
99 $(top_builddir)/src/core/libgnunetcore.la \
100 $(top_builddir)/src/dht/libgnunetdht.la \
101 $(top_builddir)/src/statistics/libgnunetstatistics.la \
102 $(top_builddir)/src/block/libgnunetblock.la
103if LINUX
104 gnunet_service_mesh_enc_LDFLAGS = -lrt
105endif
106
107
86if HAVE_TESTING 108if HAVE_TESTING
87noinst_LIBRARIES = libgnunetmeshtest.a $(noinst_LIB_EXP) 109noinst_LIBRARIES = libgnunetmeshtest.a $(noinst_LIB_EXP)
88endif 110endif