aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorPhilipp Tölke <toelke@in.tum.de>2011-01-10 21:41:42 +0000
committerPhilipp Tölke <toelke@in.tum.de>2011-01-10 21:41:42 +0000
commit85aebf0bc477953b80f62bd26cd528a8932501a4 (patch)
treedab931f057662abd2ec5c9fa980d2280a68c755a /src/mesh/Makefile.am
parent439d18149cd4b6e548a2b6f6510fbbd625dda6b4 (diff)
downloadgnunet-85aebf0bc477953b80f62bd26cd528a8932501a4.tar.gz
gnunet-85aebf0bc477953b80f62bd26cd528a8932501a4.zip
Mockup for the mesh-api
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
new file mode 100644
index 000000000..b7b248f39
--- /dev/null
+++ b/src/mesh/Makefile.am
@@ -0,0 +1,23 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12
13lib_LTLIBRARIES = \
14 libgnunetmesh.la
15
16libgnunetmesh_la_SOURCES = \
17 mesh_api.c
18libgnunetmesh_la_LIBADD = \
19 $(top_builddir)/src/util/libgnunetutil.la \
20 $(GN_LIBINTL) $(XLIB)
21libgnunetmesh_la_LDFLAGS = \
22 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
23 -version-info 0:0:0