aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2011-10-20 14:10:28 +0000
committerBart Polot <bart@net.in.tum.de>2011-10-20 14:10:28 +0000
commit9aa7853d6c5fa43d0384ae79476bb45242af61fb (patch)
tree8d81c58b5687bf52b2bf80f0f53826f3a0c5c782 /src/mesh/Makefile.am
parent85e2435610b558e583f10eb6fe5a8f73d7aab3a7 (diff)
downloadgnunet-9aa7853d6c5fa43d0384ae79476bb45242af61fb.tar.gz
gnunet-9aa7853d6c5fa43d0384ae79476bb45242af61fb.zip
Changed testcases structure
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am21
1 files changed, 6 insertions, 15 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 2c4dc0b4c..4e7e5c323 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -54,7 +54,6 @@ check_PROGRAMS = \
54 test_mesh_path_api \ 54 test_mesh_path_api \
55 test_mesh_local_1 \ 55 test_mesh_local_1 \
56 test_mesh_local_2 \ 56 test_mesh_local_2 \
57 test_mesh_small \
58 test_mesh_small_unicast \ 57 test_mesh_small_unicast \
59 test_mesh_small_unicast_far \ 58 test_mesh_small_unicast_far \
60 test_mesh_small_multicast 59 test_mesh_small_multicast
@@ -93,17 +92,8 @@ test_mesh_local_2_LDADD = \
93test_mesh_local_2_DEPENDENCIES = \ 92test_mesh_local_2_DEPENDENCIES = \
94 libgnunetmeshnew.la 93 libgnunetmeshnew.la
95 94
96test_mesh_small_SOURCES = \
97 test_mesh_small.c
98test_mesh_small_LDADD = \
99 $(top_builddir)/src/mesh/libgnunetmeshnew.la \
100 $(top_builddir)/src/util/libgnunetutil.la \
101 $(top_builddir)/src/testing/libgnunettesting.la
102test_mesh_small_DEPENDENCIES = \
103 libgnunetmeshnew.la
104
105test_mesh_small_unicast_SOURCES = \ 95test_mesh_small_unicast_SOURCES = \
106 test_mesh_small_unicast.c 96 test_mesh_small.c
107test_mesh_small_unicast_LDADD = \ 97test_mesh_small_unicast_LDADD = \
108 $(top_builddir)/src/mesh/libgnunetmeshnew.la \ 98 $(top_builddir)/src/mesh/libgnunetmeshnew.la \
109 $(top_builddir)/src/util/libgnunetutil.la \ 99 $(top_builddir)/src/util/libgnunetutil.la \
@@ -112,7 +102,7 @@ test_mesh_small_unicast_DEPENDENCIES = \
112 libgnunetmeshnew.la 102 libgnunetmeshnew.la
113 103
114test_mesh_small_unicast_far_SOURCES = \ 104test_mesh_small_unicast_far_SOURCES = \
115 test_mesh_small_unicast_far.c 105 test_mesh_small.c
116test_mesh_small_unicast_far_LDADD = \ 106test_mesh_small_unicast_far_LDADD = \
117 $(top_builddir)/src/mesh/libgnunetmeshnew.la \ 107 $(top_builddir)/src/mesh/libgnunetmeshnew.la \
118 $(top_builddir)/src/util/libgnunetutil.la \ 108 $(top_builddir)/src/util/libgnunetutil.la \
@@ -121,7 +111,7 @@ test_mesh_small_unicast_far_DEPENDENCIES = \
121 libgnunetmeshnew.la 111 libgnunetmeshnew.la
122 112
123test_mesh_small_multicast_SOURCES = \ 113test_mesh_small_multicast_SOURCES = \
124 test_mesh_small_multicast.c 114 test_mesh_small.c
125test_mesh_small_multicast_LDADD = \ 115test_mesh_small_multicast_LDADD = \
126 $(top_builddir)/src/mesh/libgnunetmeshnew.la \ 116 $(top_builddir)/src/mesh/libgnunetmeshnew.la \
127 $(top_builddir)/src/util/libgnunetutil.la \ 117 $(top_builddir)/src/util/libgnunetutil.la \
@@ -131,9 +121,10 @@ test_mesh_small_multicast_DEPENDENCIES = \
131 121
132 122
133if ENABLE_TEST_RUN 123if ENABLE_TEST_RUN
134TESTS = test_mesh_api test_mesh_path_api test_mesh_local_1 test_mesh_local_2 test_mesh_small test_mesh_small_unicast 124TESTS = test_mesh_api test_mesh_path_api test_mesh_local_1 test_mesh_local_2 test_mesh_small_unicast test_mesh_small_multicast
135endif 125endif
136 126
137EXTRA_DIST = \ 127EXTRA_DIST = \
138 test_mesh.conf \ 128 test_mesh.conf \
139 test_mesh_path.conf \ No newline at end of file 129 test_mesh_path.conf \
130 test_mesh_small.conf \ No newline at end of file