aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2014-03-06 01:36:39 +0000
committerBart Polot <bart@net.in.tum.de>2014-03-06 01:36:39 +0000
commitbe3ea5ac44329494ad287596403dd06527edef47 (patch)
tree3b88fcae7ae010e1f1d7915e4fc15ac11817d5a6 /src/mesh/Makefile.am
parent26cc9b60fb8af01b9487f9c972d498f75b65c7d5 (diff)
downloadgnunet-be3ea5ac44329494ad287596403dd06527edef47.tar.gz
gnunet-be3ea5ac44329494ad287596403dd06527edef47.zip
- add makefile for new testcase
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am21
1 files changed, 15 insertions, 6 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 2775dff6c..a2bb0135b 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -100,10 +100,11 @@ check_PROGRAMS = \
100 test_mesh_single \ 100 test_mesh_single \
101 test_mesh_local \ 101 test_mesh_local \
102 test_mesh_small_forward \ 102 test_mesh_small_forward \
103 test_mesh_small_signal \ 103 test_mesh_small_signal \
104 test_mesh_small_speed \ 104 test_mesh_small_keepalive \
105 test_mesh_small_speed_ack \ 105 test_mesh_small_speed \
106 test_mesh_small_speed_backwards \ 106 test_mesh_small_speed_ack \
107 test_mesh_small_speed_backwards \
107 test_mesh_small_speed_reliable \ 108 test_mesh_small_speed_reliable \
108 test_mesh_small_speed_reliable_backwards 109 test_mesh_small_speed_reliable_backwards
109endif 110endif
@@ -113,11 +114,14 @@ ld_mesh_test_lib = \
113 $(top_builddir)/src/testing/libgnunettesting.la \ 114 $(top_builddir)/src/testing/libgnunettesting.la \
114 $(top_builddir)/src/mesh/libgnunetmeshtest.a \ 115 $(top_builddir)/src/mesh/libgnunetmeshtest.a \
115 $(top_builddir)/src/mesh/libgnunetmesh.la \ 116 $(top_builddir)/src/mesh/libgnunetmesh.la \
116 $(top_builddir)/src/testbed/libgnunettestbed.la 117 $(top_builddir)/src/testbed/libgnunettestbed.la \
118 $(top_builddir)/src/statistics/libgnunetstatistics.la
119
117 120
118dep_mesh_test_lib = \ 121dep_mesh_test_lib = \
119 libgnunetmesh.la \ 122 libgnunetmesh.la \
120 libgnunetmeshtest.a 123 libgnunetmeshtest.a \
124 $(top_builddir)/src/statistics/libgnunetstatistics.la
121 125
122test_mesh_single_SOURCES = \ 126test_mesh_single_SOURCES = \
123 test_mesh_single.c 127 test_mesh_single.c
@@ -139,6 +143,11 @@ test_mesh_small_signal_SOURCES = \
139test_mesh_small_signal_LDADD = $(ld_mesh_test_lib) 143test_mesh_small_signal_LDADD = $(ld_mesh_test_lib)
140test_mesh_small_signal_DEPENDENCIES = $(dep_mesh_test_lib) 144test_mesh_small_signal_DEPENDENCIES = $(dep_mesh_test_lib)
141 145
146test_mesh_small_keepalive_SOURCES = \
147 test_mesh_small.c
148test_mesh_small_keepalive_LDADD = $(ld_mesh_test_lib)
149test_mesh_small_keepalive_DEPENDENCIES = $(dep_mesh_test_lib)
150
142test_mesh_small_speed_SOURCES = \ 151test_mesh_small_speed_SOURCES = \
143 test_mesh_small.c 152 test_mesh_small.c
144test_mesh_small_speed_LDADD = $(ld_mesh_test_lib) 153test_mesh_small_speed_LDADD = $(ld_mesh_test_lib)