aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
committerDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
commitea7eed529e12dcbed6a6775b818d8b93b9505f18 (patch)
tree521ba312e1268d1afb249db03c1b97d5a79181a1 /src/mesh/Makefile.am
parent48e50f64d8c05b2a6dab327156ea86fc92f171cf (diff)
downloadgnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.tar.gz
gnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.zip
Make building gnunet-testing lib optional.
This is all because emscripten doesn't have getaddrinfo.
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 5a51073e8..37e9b03ef 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -125,8 +125,9 @@ if LINUX
125gnunet_service_mesh_new_LDFLAGS = -lrt 125gnunet_service_mesh_new_LDFLAGS = -lrt
126endif 126endif
127 127
128 128if HAVE_TESTING
129noinst_LIBRARIES = libgnunetmeshtest.a $(noinst_LIB_EXP) 129noinst_LIBRARIES = libgnunetmeshtest.a $(noinst_LIB_EXP)
130endif
130 131
131libgnunetmeshtest_a_SOURCES = \ 132libgnunetmeshtest_a_SOURCES = \
132 mesh_test_lib.c mesh_test_lib.h 133 mesh_test_lib.c mesh_test_lib.h
@@ -146,7 +147,7 @@ libgnunetmesh2test_a_LIBADD = \
146libgnunetmesh2test_a_DEPENDENCIES = \ 147libgnunetmesh2test_a_DEPENDENCIES = \
147 libgnunetmesh2.la 148 libgnunetmesh2.la
148 149
149 150if HAVE_TESTING
150check_PROGRAMS = \ 151check_PROGRAMS = \
151 test_mesh_api \ 152 test_mesh_api \
152 test_mesh_tree_api \ 153 test_mesh_tree_api \
@@ -164,6 +165,7 @@ check_PROGRAMS = \
164 test_mesh_small_speed_nobuf_backwards \ 165 test_mesh_small_speed_nobuf_backwards \
165 test_mesh_small_speed_ack \ 166 test_mesh_small_speed_ack \
166 $(EXP_TESTS) 167 $(EXP_TESTS)
168endif
167 169
168test_mesh_api_SOURCES = \ 170test_mesh_api_SOURCES = \
169 test_mesh_api.c 171 test_mesh_api.c