aboutsummaryrefslogtreecommitdiff
path: root/src/my/Makefile.am
diff options
context:
space:
mode:
authorChristophe Genevey Metat <genevey.christophe@gmail.com>2016-05-24 16:16:01 +0000
committerChristophe Genevey Metat <genevey.christophe@gmail.com>2016-05-24 16:16:01 +0000
commit52aa7299f2c3a9f9e80b366ca9068a6edf3b9bab (patch)
treee086c7db41ce02182a17e07e1c3d0899c398620c /src/my/Makefile.am
parenta0f69c5d40c22904549bb3246c523681d00d72cd (diff)
downloadgnunet-52aa7299f2c3a9f9e80b366ca9068a6edf3b9bab.tar.gz
gnunet-52aa7299f2c3a9f9e80b366ca9068a6edf3b9bab.zip
fix result and query helper
Diffstat (limited to 'src/my/Makefile.am')
-rw-r--r--src/my/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/my/Makefile.am b/src/my/Makefile.am
index 54e6d5563..7c0bc404e 100644
--- a/src/my/Makefile.am
+++ b/src/my/Makefile.am
@@ -15,10 +15,26 @@ endif
15 15
16libgnunetmy_la_SOURCES = \ 16libgnunetmy_la_SOURCES = \
17 my.c \ 17 my.c \
18 my_query_helper.c 18 my_query_helper.c \
19 my_result_helper.c
20
19libgnunetmy_la_LIBADD = $(MYSQL_LDFLAGS) -lmysqlclient \ 21libgnunetmy_la_LIBADD = $(MYSQL_LDFLAGS) -lmysqlclient \
20 $(top_builddir)/src/mysql/libgnunetmysql.la \ 22 $(top_builddir)/src/mysql/libgnunetmysql.la \
21 $(top_builddir)/src/util/libgnunetutil.la 23 $(top_builddir)/src/util/libgnunetutil.la
22libgnunetmy_la_LDFLAGS = \ 24libgnunetmy_la_LDFLAGS = \
23 $(GN_LIB_LDFLAGS) \ 25 $(GN_LIB_LDFLAGS) \
24 -version-info 0:0:0 26 -version-info 0:0:0
27
28TESTS = \
29 test_my
30
31check_PROGRAMS= \
32 test_my
33
34test_my_SOURCES = \
35 test_my.c
36test_my_LDADD = \
37 libgnunetmy.la \
38 $(top_builddir)/src/util/libgnunetutil.la \
39 -lmysqlclient $(XLIB)
40