aboutsummaryrefslogtreecommitdiff
path: root/src/my/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-09-24 11:13:02 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-09-24 11:13:02 +0200
commit757fe39278b2f3f29459f33c5ec41f0181142e18 (patch)
treed670abdd8b3b4da21bef3d097e4d66ddad6c5047 /src/my/Makefile.am
parent3ee4f3c6fb9986fcb67de0cb0bb32d6f12ab44cf (diff)
downloadgnunet-757fe39278b2f3f29459f33c5ec41f0181142e18.tar.gz
gnunet-757fe39278b2f3f29459f33c5ec41f0181142e18.zip
MYSQL: phase out
Diffstat (limited to 'src/my/Makefile.am')
-rw-r--r--src/my/Makefile.am41
1 files changed, 0 insertions, 41 deletions
diff --git a/src/my/Makefile.am b/src/my/Makefile.am
deleted file mode 100644
index 51e20e6bf..000000000
--- a/src/my/Makefile.am
+++ /dev/null
@@ -1,41 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage
6endif
7
8if HAVE_MYSQL
9lib_LTLIBRARIES = libgnunetmy.la
10endif
11
12libgnunetmy_la_SOURCES = \
13 my.c \
14 my_query_helper.c \
15 my_result_helper.c
16
17libgnunetmy_la_LIBADD = $(MYSQL_LDFLAGS) -lmysqlclient \
18 $(top_builddir)/src/mysql/libgnunetmysql.la \
19 $(top_builddir)/src/util/libgnunetutil.la
20libgnunetmy_la_LDFLAGS = \
21 $(GN_LIB_LDFLAGS) \
22 -version-info 0:0:0
23
24if ENABLE_TEST_RUN
25TESTS = \
26 test_my
27endif
28
29EXTRA_DIST = \
30 test_my.conf
31
32check_PROGRAMS= \
33 test_my
34
35test_my_SOURCES = \
36 test_my.c
37test_my_LDADD = \
38 libgnunetmy.la \
39 $(top_builddir)/src/mysql/libgnunetmysql.la \
40 $(top_builddir)/src/util/libgnunetutil.la \
41 -lmysqlclient $(XLIB)