aboutsummaryrefslogtreecommitdiff
path: root/src/mysql/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-03-21 09:43:54 +0000
committerChristian Grothoff <christian@grothoff.org>2012-03-21 09:43:54 +0000
commit3343e64659d6e8ff5ed6a74faac7226e55fc1c55 (patch)
tree0e4a00025d80fd39e043019dccbd67f8c483328d /src/mysql/Makefile.am
parent422593416288a25c3fa062fffd81525aa50830d0 (diff)
downloadgnunet-3343e64659d6e8ff5ed6a74faac7226e55fc1c55.tar.gz
gnunet-3343e64659d6e8ff5ed6a74faac7226e55fc1c55.zip
creating mysql helper library for the various mysql backends
Diffstat (limited to 'src/mysql/Makefile.am')
-rw-r--r--src/mysql/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/mysql/Makefile.am b/src/mysql/Makefile.am
new file mode 100644
index 000000000..1711e7572
--- /dev/null
+++ b/src/mysql/Makefile.am
@@ -0,0 +1,20 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage
9endif
10
11lib_LTLIBRARIES = libgnunetmysql.la
12
13libgnunetmysql_la_SOURCES = \
14 mysql.c
15libgnunetmysql_la_LIBADD = -lmysqlclient \
16 $(top_builddir)/src/util/libgnunetutil.la
17libgnunetmysql_la_LDFLAGS = \
18 $(GN_LIB_LDFLAGS) \
19 -version-info 0:0:0
20