aboutsummaryrefslogtreecommitdiff
path: root/src/namecache/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-16 19:32:52 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-16 19:32:52 +0000
commit6308c2556c54ea8a19b33bfe16bd2f81eae65e86 (patch)
tree2017381fa55744868e3664b59a46d60cce8c2433 /src/namecache/Makefile.am
parente71d2567fc6d2634c503587ba481cc92f5f5e60e (diff)
downloadgnunet-6308c2556c54ea8a19b33bfe16bd2f81eae65e86.tar.gz
gnunet-6308c2556c54ea8a19b33bfe16bd2f81eae65e86.zip
-copied block-related functions from namestore to namecache
Diffstat (limited to 'src/namecache/Makefile.am')
-rw-r--r--src/namecache/Makefile.am164
1 files changed, 164 insertions, 0 deletions
diff --git a/src/namecache/Makefile.am b/src/namecache/Makefile.am
new file mode 100644
index 000000000..b8ad9b7fa
--- /dev/null
+++ b/src/namecache/Makefile.am
@@ -0,0 +1,164 @@
1AM_CPPFLAGS = -I$(top_srcdir)/src/include
2
3plugindir = $(libdir)/gnunet
4
5pkgcfgdir= $(pkgdatadir)/config.d/
6
7libexecdir= $(pkglibdir)/libexec/
8
9pkgcfg_DATA = \
10 namecache.conf
11
12
13if MINGW
14 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
15endif
16
17if USE_COVERAGE
18 AM_CFLAGS = --coverage -O0
19 XLIBS = -lgcov
20endif
21
22if HAVE_SQLITE
23SQLITE_PLUGIN = libgnunet_plugin_namecache_sqlite.la
24if HAVE_TESTING
25SQLITE_TESTS = test_plugin_namecache_sqlite
26endif
27endif
28
29if HAVE_POSTGRES
30POSTGRES_PLUGIN = libgnunet_plugin_namecache_postgres.la
31if HAVE_TESTING
32POSTGRES_TESTS = test_plugin_namecache_postgres
33endif
34endif
35
36# testcases do not even build yet; thus: experimental!
37if HAVE_TESTING
38TESTING_TESTS = \
39 test_namecache_api_cache_block
40endif
41
42if HAVE_SQLITE
43check_PROGRAMS = \
44 $(SQLITE_TESTS) \
45 $(POSTGRES_TESTS) \
46 $(TESTING_TESTS)
47endif
48
49if ENABLE_TEST_RUN
50TESTS = \
51 $(check_PROGRAMS)
52endif
53
54lib_LTLIBRARIES = \
55 libgnunetnamecache.la
56
57
58libgnunetnamecache_la_SOURCES = \
59 namecache_api.c \
60 namecache.h
61libgnunetnamecache_la_LIBADD = \
62 $(top_builddir)/src/util/libgnunetutil.la \
63 $(GN_LIBINTL)
64libgnunetnamecache_la_LDFLAGS = \
65 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
66 -version-info 0:0:0
67
68
69libexec_PROGRAMS = \
70 gnunet-service-namecache
71
72bin_PROGRAMS = \
73 gnunet-namecache
74
75gnunet_namecache_SOURCES = \
76 gnunet-namecache.c
77gnunet_namecache_LDADD = \
78 $(top_builddir)/src/namestore/libgnunetnamestore.la \
79 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
80 $(top_builddir)/src/util/libgnunetutil.la \
81 libgnunetnamecache.la \
82 $(GN_LIBINTL)
83gnunet_namecache_DEPENDENCIES = \
84 $(top_builddir)/src/identity/libgnunetidentity.la \
85 $(top_builddir)/src/util/libgnunetutil.la \
86 libgnunetnamecache.la
87
88
89gnunet_service_namecache_SOURCES = \
90 gnunet-service-namecache.c
91
92gnunet_service_namecache_LDADD = \
93 $(top_builddir)/src/namestore/libgnunetnamestore.la \
94 $(top_builddir)/src/statistics/libgnunetstatistics.la \
95 $(top_builddir)/src/util/libgnunetutil.la \
96 libgnunetnamecache.la \
97 $(GN_LIBINTL)
98gnunet_service_namecache_DEPENDENCIES = \
99 $(top_builddir)/src/statistics/libgnunetstatistics.la \
100 $(top_builddir)/src/util/libgnunetutil.la \
101 libgnunetnamecache.la
102
103
104plugin_LTLIBRARIES = \
105 $(SQLITE_PLUGIN) \
106 $(POSTGRES_PLUGIN)
107
108libgnunet_plugin_namecache_sqlite_la_SOURCES = \
109 plugin_namecache_sqlite.c
110libgnunet_plugin_namecache_sqlite_la_LIBADD = \
111 $(top_builddir)/src/namecache/libgnunetnamecache.la \
112 $(top_builddir)/src/statistics/libgnunetstatistics.la \
113 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
114 $(LTLIBINTL)
115libgnunet_plugin_namecache_sqlite_la_LDFLAGS = \
116 $(GN_PLUGIN_LDFLAGS)
117libgnunet_plugin_namecache_sqlite_la_DEPENDENCIES = \
118 $(top_builddir)/src/statistics/libgnunetstatistics.la \
119 $(top_builddir)/src/util/libgnunetutil.la \
120 libgnunetnamecache.la
121
122
123libgnunet_plugin_namecache_postgres_la_SOURCES = \
124 plugin_namecache_postgres.c
125libgnunet_plugin_namecache_postgres_la_LIBADD = \
126 $(top_builddir)/src/namecache/libgnunetnamecache.la \
127 $(top_builddir)/src/postgres/libgnunetpostgres.la \
128 $(top_builddir)/src/statistics/libgnunetstatistics.la \
129 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq \
130 $(LTLIBINTL)
131libgnunet_plugin_namecache_postgres_la_LDFLAGS = \
132 $(GN_PLUGIN_LDFLAGS)
133libgnunet_plugin_namecache_postgres_la_DEPENDENCIES = \
134 $(top_builddir)/src/postgres/libgnunetpostgres.la \
135 $(top_builddir)/src/statistics/libgnunetstatistics.la \
136 $(top_builddir)/src/util/libgnunetutil.la \
137 libgnunetnamecache.la
138
139test_namecache_api_cache_block_SOURCES = \
140 test_namecache_api_cache_block.c
141test_namecache_api_cache_block_LDADD = \
142 $(top_builddir)/src/namestore/libgnunetnamestore.la \
143 $(top_builddir)/src/namecache/libgnunetnamecache.la \
144 $(top_builddir)/src/testing/libgnunettesting.la \
145 $(top_builddir)/src/util/libgnunetutil.la
146
147test_plugin_namecache_sqlite_SOURCES = \
148 test_plugin_namecache.c
149test_plugin_namecache_sqlite_LDADD = \
150 $(top_builddir)/src/testing/libgnunettesting.la \
151 $(top_builddir)/src/util/libgnunetutil.la
152
153test_plugin_namecache_postgres_SOURCES = \
154 test_plugin_namecache.c
155test_plugin_namecache_postgres_LDADD = \
156 $(top_builddir)/src/testing/libgnunettesting.la \
157 $(top_builddir)/src/util/libgnunetutil.la
158
159EXTRA_DIST = \
160 test_namecache_api.conf \
161 test_plugin_namecache_sqlite.conf \
162 test_plugin_namecache_postgres.conf \
163 test_namecache_defaults.conf
164