aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-09-23 12:44:45 +0900
committerMartin Schanzenbach <schanzen@gnunet.org>2022-09-23 12:44:45 +0900
commit52babbd648cd8b9ab7f49f26641f8ccf7d2fc4e8 (patch)
treef49953af9a446eab96a985e7e3f58ef948bc5011 /src/namestore/Makefile.am
parent127ad07a3abaee00fb206aaf8b980f258d2933c8 (diff)
downloadgnunet-52babbd648cd8b9ab7f49f26641f8ccf7d2fc4e8.tar.gz
gnunet-52babbd648cd8b9ab7f49f26641f8ccf7d2fc4e8.zip
NAMESTORE: Add begin, commit and rollback API messages
Namestore service can now handle begin commit and rollback. A test for rollback exists and works for sqlite.
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 51708dd67..58e3c49f0 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -54,7 +54,8 @@ SQLITE_TESTS = test_plugin_namestore_sqlite \
54 test_namestore_api_zone_iteration_stop_sqlite \ 54 test_namestore_api_zone_iteration_stop_sqlite \
55 test_namestore_api_monitoring_existing_sqlite \ 55 test_namestore_api_monitoring_existing_sqlite \
56 test_namestore_api_zone_to_name_sqlite \ 56 test_namestore_api_zone_to_name_sqlite \
57 perf_namestore_api_zone_iteration_sqlite 57 perf_namestore_api_zone_iteration_sqlite \
58 test_namestore_api_tx_rollback_sqlite
58endif 59endif
59 60
60if HAVE_POSTGRESQL 61if HAVE_POSTGRESQL
@@ -569,6 +570,16 @@ test_namestore_api_monitoring_existing_postgres_LDADD = \
569 $(top_builddir)/src/identity/libgnunetidentity.la \ 570 $(top_builddir)/src/identity/libgnunetidentity.la \
570 $(top_builddir)/src/util/libgnunetutil.la 571 $(top_builddir)/src/util/libgnunetutil.la
571 572
573test_namestore_api_tx_rollback_sqlite_SOURCES = \
574 test_namestore_api_tx_rollback.c
575test_namestore_api_tx_rollback_sqlite_LDADD = \
576 $(top_builddir)/src/testing/libgnunettesting.la \
577 $(top_builddir)/src/identity/libgnunetidentity.la \
578 libgnunetnamestore.la \
579 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
580 $(top_builddir)/src/util/libgnunetutil.la
581
582
572test_namestore_api_zone_iteration_flat_SOURCES = \ 583test_namestore_api_zone_iteration_flat_SOURCES = \
573 test_namestore_api_zone_iteration.c 584 test_namestore_api_zone_iteration.c
574test_namestore_api_zone_iteration_flat_LDADD = \ 585test_namestore_api_zone_iteration_flat_LDADD = \